summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-11-04 11:12:06 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-11-04 11:14:11 +1100
commitb0af7b2ae386501831921a5843f57a6845a0b300 (patch)
treedd88ce516de8a888ab8b5bd32c35190747cd1f71 /kde-frameworks/kirigami
parentapp-misc/egads: EAPI 6 bump. (diff)
downloadgentoo-b0af7b2ae386501831921a5843f57a6845a0b300.tar.gz
gentoo-b0af7b2ae386501831921a5843f57a6845a0b300.tar.bz2
gentoo-b0af7b2ae386501831921a5843f57a6845a0b300.zip
kde-frameworks/kirigami: backport patch from upstream solving runtime failure with Qt 5.7
Closes: https://bugs.gentoo.org/634564 Package-Manager: Portage-2.3.8, Repoman-2.3.4
Diffstat (limited to 'kde-frameworks/kirigami')
-rw-r--r--kde-frameworks/kirigami/files/kirigami-5.39.0-qt57.patch27
-rw-r--r--kde-frameworks/kirigami/kirigami-5.39.0-r1.ebuild45
2 files changed, 72 insertions, 0 deletions
diff --git a/kde-frameworks/kirigami/files/kirigami-5.39.0-qt57.patch b/kde-frameworks/kirigami/files/kirigami-5.39.0-qt57.patch
new file mode 100644
index 000000000000..de33976061db
--- /dev/null
+++ b/kde-frameworks/kirigami/files/kirigami-5.39.0-qt57.patch
@@ -0,0 +1,27 @@
+From eed28bbd8aec29cb9a045a5188ceb0e27ff33344 Mon Sep 17 00:00:00 2001
+From: Marco Martin <notmart@gmail.com>
+Date: Fri, 3 Nov 2017 16:57:11 +0100
+Subject: [PATCH] syntax working on older Qt 5.7
+
+BUG:385785
+---
+ src/controls/Page.qml | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/controls/Page.qml b/src/controls/Page.qml
+index c2d0307..4498e40 100644
+--- a/src/controls/Page.qml
++++ b/src/controls/Page.qml
+@@ -256,7 +256,8 @@ T2.Page {
+ right: parent.right
+ bottom: parent.bottom
+ }
+- property T2.Page page: root
++ //It should be T2.Page, Qt 5.7 doesn't like it
++ property Item page: root
+ height: item ? item.height : 0
+ source: (applicationWindow().header && applicationWindow().header.toString().indexOf("ToolBarApplicationHeader") === 0) ||
+ (applicationWindow().footer && applicationWindow().footer.visible && applicationWindow().footer.toString().indexOf("ToolBarApplicationHeader") === 0)
+--
+2.13.6
+
diff --git a/kde-frameworks/kirigami/kirigami-5.39.0-r1.ebuild b/kde-frameworks/kirigami/kirigami-5.39.0-r1.ebuild
new file mode 100644
index 000000000000..f18881398a78
--- /dev/null
+++ b/kde-frameworks/kirigami/kirigami-5.39.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_EXAMPLES="true"
+KDE_QTHELP="false"
+KDE_TEST="forceoptional"
+KMNAME="${PN}2"
+inherit kde5
+
+DESCRIPTION="Lightweight user interface framework for mobile and convergent applications"
+HOMEPAGE="https://techbase.kde.org/Kirigami"
+EGIT_REPO_URI="${EGIT_REPO_URI/${PN}2/${PN}}"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="plasma"
+
+RDEPEND="
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgraphicaleffects)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtquickcontrols2)
+ $(add_qt_dep qtsvg)
+ plasma? ( $(add_frameworks_dep plasma) )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep linguist-tools)
+"
+
+# requires package to already be installed
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-qt57.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples)
+ -DPLASMA_ENABLED=$(usex plasma)
+ )
+
+ kde5_src_configure
+}