summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 01:41:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 14:09:23 +0200
commite15ecc6fd48561f6d1784aeef448c0e788e78a8e (patch)
treedfce708698c253d8d51b19fd5be0e6da08d722b7 /kde-frameworks/frameworkintegration
parentkde-apps/dolphin: Fix startup error message (diff)
downloadgentoo-e15ecc6fd48561f6d1784aeef448c0e788e78a8e.tar.gz
gentoo-e15ecc6fd48561f6d1784aeef448c0e788e78a8e.tar.bz2
gentoo-e15ecc6fd48561f6d1784aeef448c0e788e78a8e.zip
kde-frameworks/frameworkintegration: 5.82.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.82.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index e931e709b4ee..33d39d4d44e3 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.80.0.tar.xz 1755248 BLAKE2B 55aecf28bc801ed72689bb340c28b1ee1374a913d98750a1380f91a36f6fcbe5f1e8690dffb74eb9fc642c578b5d6ca68937bfc95a52bdf7febaebe32d793ce9 SHA512 3e54729281d5fde4d18eaf7ebe18c6c17d1bb40e336ba0d91ac04aefd65800208efbcca4438a3be3f408860467c80bdf8b16b021c9892fec8f4ee55a13813ee2
DIST frameworkintegration-5.81.0.tar.xz 1755808 BLAKE2B 991f1322d6c976b4e49458059dca4e735cb9756bba2a1fa37ad9e317cdb92fb3856ce5499c152006ae6cd12cebe8e1f87eb6e88898cc3129c959730c94f121c5 SHA512 f76036fc378b77225cd82ffa71d39f9b321a58ab3ebb1a523457cb320c87d157e2625389e259286c4a62c5b1def12b6c94c1d5b9cb5b6e983845ead9b1110245
+DIST frameworkintegration-5.82.0.tar.xz 1755828 BLAKE2B 18c056daf8db8e06995d3f0b6985f9aabb05e8a4e7323635faf92701f04dbf135cf63221fe739504d2ccd7718dd02a6718ab7fa7ba84b86cb37394ff878b6e3f SHA512 5865e560789c50829c5648365db58497d0da141d1699f396ca431740e6f919ef68c89e2cb98ac1f320cdb07fae098de683b17c920f79a2b459ffd874935b6e77
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.82.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.82.0.ebuild
new file mode 100644
index 000000000000..8fbf5abdb53b
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.82.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT+=" test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}