summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-15 12:37:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-15 17:12:47 +0200
commit14666358bcbc6116cc1ed18e1b697be67a459f2c (patch)
treec9dc36c5b750d2856590410b380791610ec41cf3 /kde-apps/print-manager
parentmedia-gfx/imagemagick: drop old (diff)
downloadgentoo-14666358bcbc6116cc1ed18e1b697be67a459f2c.tar.gz
gentoo-14666358bcbc6116cc1ed18e1b697be67a459f2c.tar.bz2
gentoo-14666358bcbc6116cc1ed18e1b697be67a459f2c.zip
kde-apps: Add KDE Release Service 20.04.1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/print-manager')
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/print-manager-20.04.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
index 3b9351dccc1b..b1196c044783 100644
--- a/kde-apps/print-manager/Manifest
+++ b/kde-apps/print-manager/Manifest
@@ -1,2 +1,3 @@
DIST print-manager-19.12.3.tar.xz 251568 BLAKE2B 52f7ef3911c42c04a51ea1b7d398c312e1e77ebcac65cb29859aaaaa7250aed16035868c55738fcf1f6004d4ad7e70eefcb6bfb3e1387e18fdd3ccd4f47565fb SHA512 58b65aab504d1f51d238dad6ebbbc717573ec8a332807a3ca93a74d82d753255175a1b4609bef019209e03760e98853f0ce75bbee6a6141af72c7e77c84e3d36
DIST print-manager-20.04.0.tar.xz 255588 BLAKE2B 885e6486cfc3934f3724bf723cb2753f01cb576d11fc2e369342579fe60f601a242755b782fc075948d757ad2eeb898ec5e7ac2d9582dcc297579b13956b9329 SHA512 19829cafc10dd129ad2522be6843f9bf80017a7e289a51ae319371790bdcb076ea5a2e9479828a27b5f506a2c62282c71678faf5b64f42493158ec5ca40dcd61
+DIST print-manager-20.04.1.tar.xz 255660 BLAKE2B 86938a9942f3adc7c88dad9d46d9e971292c1faa5f62a23b3c036140e7b915e302281ec132ae4dda680bc49bdde0defbc509a6694d1187663468811163b6ceef SHA512 08cfbc946da55265a28e917727ad733b933adbe517d3d6e796c47249ddb489fcf1704cb198e653302217a1a456c5f5c4f54938338a57d7b42aedfc1ba9eca0c4
diff --git a/kde-apps/print-manager/print-manager-20.04.1.ebuild b/kde-apps/print-manager/print-manager-20.04.1.ebuild
new file mode 100644
index 000000000000..7c9b7cdfa924
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-20.04.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.70.0
+PLASMA_MINIMAL=5.16.5
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Manage print jobs and printers in Plasma"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ >=kde-plasma/kde-cli-tools-${PLASMA_MINIMAL}:5
+ gtk? ( app-admin/system-config-printer )
+"
+
+pkg_postinst(){
+ ecm_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! use gtk ; then
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ fi
+}