summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-21 21:22:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-08-21 21:35:53 +0200
commit384f80153eacb97f62b8374dad7b201adc1dbcad (patch)
tree31b4444c869cdd50453e700779f507b9e4637c7b /kde-apps/marble/files
parentapp-crypt/gpgme: add 1.22.0 (diff)
downloadgentoo-384f80153eacb97f62b8374dad7b201adc1dbcad.tar.gz
gentoo-384f80153eacb97f62b8374dad7b201adc1dbcad.tar.bz2
gentoo-384f80153eacb97f62b8374dad7b201adc1dbcad.zip
kde-apps/marble: Fix build against >=dev-libs/protobuf-23.3
Bug: https://bugs.gentoo.org/909081 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/marble/files')
-rw-r--r--kde-apps/marble/files/marble-23.04.3-cxx17-for-protobuf-23.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-apps/marble/files/marble-23.04.3-cxx17-for-protobuf-23.patch b/kde-apps/marble/files/marble-23.04.3-cxx17-for-protobuf-23.patch
new file mode 100644
index 000000000000..b03f800bf19d
--- /dev/null
+++ b/kde-apps/marble/files/marble-23.04.3-cxx17-for-protobuf-23.patch
@@ -0,0 +1,29 @@
+From dea7bb66fb0b89990c2ca69606d51f02af6c4cf1 Mon Sep 17 00:00:00 2001
+From: Albert Astals Cid <aacid@kde.org>
+Date: Tue, 11 Jul 2023 23:31:01 +0200
+Subject: [PATCH] Require C++17
+
+Newer protobuf will fail to compile without C++17
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c6d0e47ac0..b779501047 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -32,9 +32,9 @@ if ("${CMAKE_C_COMPILER_ID}" STREQUAL "GNU" OR "${CMAKE_C_COMPILER_ID}" STREQUAL
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=iso9899:1990")
+ endif()
+ if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU" OR "${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++17")
+ elseif ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Intel" AND NOT WIN32)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++17")
+ endif()
+ # Default to hidden visibility for symbols
+ set(CMAKE_C_VISIBILITY_PRESET hidden)
+--
+GitLab
+