summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-04-04 21:31:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-04-05 00:27:03 +0200
commit94397c78af98823d6d8b0e4279182db808b53fbe (patch)
tree0eb01168d136cdfa352a25e85a4d3954209f2ce3 /kde-apps/ktouch
parentkde-apps/kqtquickcharts: drop 22.08.3 (diff)
downloadgentoo-94397c78af98823d6d8b0e4279182db808b53fbe.tar.gz
gentoo-94397c78af98823d6d8b0e4279182db808b53fbe.tar.bz2
gentoo-94397c78af98823d6d8b0e4279182db808b53fbe.zip
kde-apps/ktouch: drop 22.08.3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ktouch')
-rw-r--r--kde-apps/ktouch/Manifest1
-rw-r--r--kde-apps/ktouch/files/ktouch-22.07.90-without_x11.patch97
-rw-r--r--kde-apps/ktouch/ktouch-22.08.3.ebuild65
3 files changed, 0 insertions, 163 deletions
diff --git a/kde-apps/ktouch/Manifest b/kde-apps/ktouch/Manifest
index d999663427d4..e4bccdd8478c 100644
--- a/kde-apps/ktouch/Manifest
+++ b/kde-apps/ktouch/Manifest
@@ -1,2 +1 @@
-DIST ktouch-22.08.3.tar.xz 4989008 BLAKE2B 5ed61941cced05ec564bcbf0f20d4bc4cd16d5b5de938f88d9081c65eb9b535f3610bb992a6ec22be4b898e9ef3f80ab9e95d08aa97644c8b366144de7c76e15 SHA512 e2c6a4be8c51e41704d55c442b46de4495e68a05dc3322efdfd74e96fd683e157594b27dec665cd5bceeffa7cbc46dc9c7ca8cf7c1ad09ec3f71e487d79a6d1d
DIST ktouch-22.12.3.tar.xz 5034456 BLAKE2B 6ee4cf93b36b719f0531f0ac057f5708a05131b1c9a2811eec693817de3a1e2ccf53ca629d1a5d8fed69a424134c0523627a96d680034801c4c588df2462e51c SHA512 ee23b0fb0edfc65a12a34539301c040e448c83e9acb723a15c8cdaf7afb62c8b5aa8ef946675a96745d5d7f5b00f5a9e615b70e6a746ac2aedfb43faf00e8abd
diff --git a/kde-apps/ktouch/files/ktouch-22.07.90-without_x11.patch b/kde-apps/ktouch/files/ktouch-22.07.90-without_x11.patch
deleted file mode 100644
index dbfc2d94987b..000000000000
--- a/kde-apps/ktouch/files/ktouch-22.07.90-without_x11.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-From d290b2a51d5aa4694ec746ce5cc9456977efde71 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Sun, 31 Jul 2022 16:17:30 +0200
-Subject: [PATCH] Add CMake option to build WITHOUT_X11
-
-We want to be able to build without X11 support even if some of the used
-libraries may not work w/o X11 themselves yet or need to be built with
-X11 support for other reverse dependencies.
-
-KTOUCH_BUILD_WITH_X11 already exists and is set automagically so far,
-but using -DCMAKE_DISABLE_FIND_PACKAGE_X11 will break if any
-dependencies list X11 as required in their cmake config.
-
-Introducing this option means there is no behavior change by default,
-cmake will just skip finding X11 or adding unwanted features if the
-option is enabled.
-
-- Move the checks to root CMakeLists.txt
-- Move finding Qt5X11Extras behind "NOT WITHOUT_X11" too
-- x11_helper is conditional on KTOUCH_BUILD_WITH_X11
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- CMakeLists.txt | 18 +++++++++++++++---
- src/CMakeLists.txt | 13 +------------
- 2 files changed, 16 insertions(+), 15 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 9ec74a5..a05231b 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -39,9 +39,6 @@ find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} REQUIRED COMPONENTS
- Xml
- XmlPatterns
- )
--if (QT_MAJOR_VERSION STREQUAL "5")
--find_package(Qt5X11Extras)
--endif()
- find_package(Qt${QT_MAJOR_VERSION} CONFIG QUIET OPTIONAL_COMPONENTS QuickCompiler)
-
- find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
-@@ -62,6 +59,21 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
-
-
- option(COMPILE_QML "Precompile QML code" OFF)
-+option(WITHOUT_X11 "Build without X11 Keyboard Layout Detection (skips finding X11)" OFF)
-+
-+if (NOT WITHOUT_X11)
-+ find_package(X11)
-+ find_package(XCB OPTIONAL_COMPONENTS XCB XKB)
-+ if (QT_MAJOR_VERSION STREQUAL "5")
-+ find_package(Qt5X11Extras ${QT_MIN_VERSION} CONFIG)
-+ endif()
-+
-+ if (Qt5X11Extras_FOUND AND X11_FOUND AND X11_Xkbfile_FOUND AND X11_Xkb_FOUND AND XCB_FOUND AND XCB_XKB_FOUND)
-+ set(KTOUCH_BUILD_WITH_X11 TRUE)
-+ endif()
-+
-+ add_feature_info ("Keyboard Layout Detection" KTOUCH_BUILD_WITH_X11 "needs Qt5X11Extras, libX11, libxkb, libxkbfile, libxcb, and libxcb-xkb")
-+endif()
-
- # enable QML debugging for debug builds
- set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DQT_QML_DEBUG")
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index cb6f3f5..9dd2a5f 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -4,15 +4,6 @@ ecm_setup_version(${RELEASE_SERVICE_VERSION}
- PACKAGE_VERSION_FILE "${CMAKE_CURRENT_BINARY_DIR}/KTouchConfigVersion.cmake"
- )
-
--find_package(X11)
--find_package(XCB OPTIONAL_COMPONENTS XCB XKB)
--
--if (Qt5X11Extras_FOUND AND X11_FOUND AND X11_Xkbfile_FOUND AND X11_Xkb_FOUND AND XCB_FOUND AND XCB_XKB_FOUND)
-- set(KTOUCH_BUILD_WITH_X11 TRUE)
--endif()
--
--add_feature_info ("Keyboard Layout Detection" KTOUCH_BUILD_WITH_X11 "needs Qt5X11Extras, libX11, libxkb, libxkbfile, libxcb, and libxcb-xkb")
--
- ecm_optional_add_subdirectory(schemata)
-
- # set include directories
-@@ -137,9 +128,7 @@ set(ktouch_SRCS
- undocommands/coursecommands.cpp
- undocommands/coursecommands.h
- undocommands/keyboardlayoutcommands.cpp
-- undocommands/keyboardlayoutcommands.h
-- x11_helper.cpp
-- x11_helper.h)
-+ undocommands/keyboardlayoutcommands.h)
-
- qt_add_resources(ktouch_imgs_SRCS images/images.qrc)
-
---
-GitLab
-
diff --git a/kde-apps/ktouch/ktouch-22.08.3.ebuild b/kde-apps/ktouch/ktouch-22.08.3.ebuild
deleted file mode 100644
index 713f8034926d..000000000000
--- a/kde-apps/ktouch/ktouch-22.08.3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_HANDBOOK="forceoptional"
-PVCUT=$(ver_cut 1-3)
-KFMIN=5.96.0
-QTMIN=5.15.5
-inherit ecm gear.kde.org
-
-DESCRIPTION="Program that helps to learn and practice touch typing"
-HOMEPAGE="https://apps.kde.org/ktouch/"
-
-LICENSE="GPL-2" # TODO: CHECK
-SLOT="5"
-KEYWORDS="amd64 arm64 ~riscv x86"
-IUSE="X"
-
-COMMON_DEPEND="
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtquickcontrols2-${QTMIN}:5
- >=dev-qt/qtsql-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- >=dev-qt/qtxmlpatterns-${QTMIN}:5
- >=kde-frameworks/kcmutils-${KFMIN}:5
- >=kde-frameworks/kcompletion-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kiconthemes-${KFMIN}:5
- >=kde-frameworks/kitemviews-${KFMIN}:5
- >=kde-frameworks/kservice-${KFMIN}:5
- >=kde-frameworks/ktextwidgets-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- X? (
- >=dev-qt/qtx11extras-${QTMIN}:5
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libxcb
- x11-libs/libxkbfile
- )
-"
-DEPEND="${COMMON_DEPEND}
- >=kde-frameworks/kwindowsystem-${KFMIN}:5
-"
-RDEPEND="${COMMON_DEPEND}
- >=dev-qt/qtgraphicaleffects-${QTMIN}:5
- >=kde-apps/kqtquickcharts-${PVCUT}:5
-"
-
-PATCHES=( "${FILESDIR}/${PN}-22.07.90-without_x11.patch" )
-
-src_configure() {
- local mycmakeargs=(
- -DCOMPILE_QML=OFF
- -DWITHOUT_X11=$(usex !X)
- )
- ecm_src_configure
-}