summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-19 15:33:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-19 15:33:37 +0200
commit1d72a0a1cd87d7401ef850a98513c7e080d7d2e1 (patch)
treecb93e377edcbd097f32d02b97f3a1a9a5d851b10 /kde-apps/kcontacts
parentsys-kernel/gentoo-sources: Linux patch 4.16.3 (diff)
downloadgentoo-1d72a0a1cd87d7401ef850a98513c7e080d7d2e1.tar.gz
gentoo-1d72a0a1cd87d7401ef850a98513c7e080d7d2e1.tar.bz2
gentoo-1d72a0a1cd87d7401ef850a98513c7e080d7d2e1.zip
kde-apps: Add KDE Applications 18.04.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'kde-apps/kcontacts')
-rw-r--r--kde-apps/kcontacts/Manifest1
-rw-r--r--kde-apps/kcontacts/files/kcontacts-18.04.0-unused-dep.patch47
-rw-r--r--kde-apps/kcontacts/kcontacts-18.04.0.ebuild41
3 files changed, 89 insertions, 0 deletions
diff --git a/kde-apps/kcontacts/Manifest b/kde-apps/kcontacts/Manifest
index 530dd8ba06d5..e7cd870a5855 100644
--- a/kde-apps/kcontacts/Manifest
+++ b/kde-apps/kcontacts/Manifest
@@ -1 +1,2 @@
DIST kcontacts-17.12.3.tar.xz 206708 BLAKE2B 8c948183fa389be754ee7a8d2928c64f9b854ce06c97fbbca79c784d8e7cd48cade5c2e6a95b3dfe77017f2fcc7bcaebc15c8fb759755b2402a50f4e7dd029e3 SHA512 e6f77cb685d6c163e575862608d127b524815704a4d124234f871aeb36abdbbe6efca26d17c86692094b395e7edf889f53cc70b7c72f33746483c9a04a674e21
+DIST kcontacts-18.04.0.tar.xz 206920 BLAKE2B 00da3c840b09526903cad4a9c51f70f7ea9c3ed2df4cdee64477312ff713d3002d008a2f0274f1b11b979619277b979978a6c408027d551ac86b3cb2447dc518 SHA512 2cd7ff23f18df20020760c8969725be683d04855949dc0b926c720a65c1e160f3a1085b1ba03b80ec86c7ed5575407a4c8f16f45142326de809c4bc1be5ba0e7
diff --git a/kde-apps/kcontacts/files/kcontacts-18.04.0-unused-dep.patch b/kde-apps/kcontacts/files/kcontacts-18.04.0-unused-dep.patch
new file mode 100644
index 000000000000..2843c6d5422b
--- /dev/null
+++ b/kde-apps/kcontacts/files/kcontacts-18.04.0-unused-dep.patch
@@ -0,0 +1,47 @@
+From fc512cee665f1e2736a701c9960efce5c093bca3 Mon Sep 17 00:00:00 2001
+From: Volker Krause <vkrause@kde.org>
+Date: Sat, 14 Apr 2018 18:08:38 +0200
+Subject: Remove unused D-Bus dependency
+
+Summary: Makes this much easier to build on Android.
+
+Reviewers: #kde_pim, dvratil
+
+Reviewed By: #kde_pim, dvratil
+
+Tags: #kde_pim
+
+Differential Revision: https://phabricator.kde.org/D12198
+---
+ CMakeLists.txt | 2 +-
+ src/CMakeLists.txt | 1 -
+ 2 files changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f47888b..87408d9 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -33,7 +33,7 @@ ecm_setup_version(PROJECT VARIABLE_PREFIX KContacts
+ )
+
+ ########### Find packages ###########
+-find_package(Qt5 ${QT_REQUIRED_VERSION} REQUIRED COMPONENTS DBus Gui)
++find_package(Qt5 ${QT_REQUIRED_VERSION} REQUIRED COMPONENTS Gui)
+ find_package(KF5 ${KF5_VERSION} REQUIRED COMPONENTS CoreAddons I18n Config Codecs)
+
+ ########### Targets ###########
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 819e7fe..e1a2094 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -63,7 +63,6 @@ PUBLIC
+ KF5::CoreAddons
+ PRIVATE
+ Qt5::Gui
+- Qt5::DBus
+ KF5::ConfigCore
+ KF5::I18n
+ KF5::Codecs # for the vcard parser
+--
+cgit v0.11.2
+
diff --git a/kde-apps/kcontacts/kcontacts-18.04.0.ebuild b/kde-apps/kcontacts/kcontacts-18.04.0.ebuild
new file mode 100644
index 000000000000..0eb69f42b2ae
--- /dev/null
+++ b/kde-apps/kcontacts/kcontacts-18.04.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Address book API based on KDE Frameworks"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_qt_dep qtgui)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+PATCHES=( "${FILESDIR}/${P}-unused-dep.patch" )
+
+src_prepare() {
+ kde5_src_prepare
+
+ # FIXME: Fails test because access to /dev/dri/card0 is denied
+ sed -i \
+ -e "/ecm_add_tests/ s/picturetest\.cpp //" \
+ autotests/CMakeLists.txt || die
+}
+
+src_test() {
+ mkdir -p "${HOME}/.local/share/kf5/kcontacts" || die
+ cp "${S}/src/countrytransl.map" "${HOME}/.local/share/kf5/kcontacts/" || die
+ kde5_src_test
+}