summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-apps/gwenview
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-apps/gwenview')
-rw-r--r--kde-apps/gwenview/Manifest1
-rw-r--r--kde-apps/gwenview/gwenview-4.14.3.ebuild64
-rw-r--r--kde-apps/gwenview/metadata.xml8
3 files changed, 73 insertions, 0 deletions
diff --git a/kde-apps/gwenview/Manifest b/kde-apps/gwenview/Manifest
new file mode 100644
index 000000000000..f3346ff52e09
--- /dev/null
+++ b/kde-apps/gwenview/Manifest
@@ -0,0 +1 @@
+DIST gwenview-4.14.3.tar.xz 2910652 SHA256 2032d18bc20ea490f3d1298e015ffac2a7b96eb7a76c02578df0713c1ab427a0 SHA512 cb64b2278adb01f0fad92d861126ff8256c80ae8780de0a37bcc1e6a0e19e2f5b14c09fc884c6d759a0cd6b3a2611787235020745147c9fc66883d61ab4861c3 WHIRLPOOL 6e786942bfb45965af7f765961822b7d2d0929facede5e197a36d67b82aaa3a036261288738fedec33e65ad117a4f14009f59eddb3f89d07ea9584f72fce103f
diff --git a/kde-apps/gwenview/gwenview-4.14.3.ebuild b/kde-apps/gwenview/gwenview-4.14.3.ebuild
new file mode 100644
index 000000000000..7ce5e1245151
--- /dev/null
+++ b/kde-apps/gwenview/gwenview-4.14.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-base
+
+DESCRIPTION="KDE image viewer"
+HOMEPAGE="
+ http://www.kde.org/applications/graphics/gwenview/
+ http://gwenview.sourceforge.net/
+"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug kipi semantic-desktop"
+
+# tests fail, last checked 4.11.0
+RESTRICT="test"
+
+DEPEND="
+ $(add_kdeapps_dep libkdcraw)
+ $(add_kdeapps_dep libkonq)
+ $(add_kdebase_dep kactivities '' 4.13)
+ media-gfx/exiv2:=
+ media-libs/lcms:2
+ media-libs/libpng:0=
+ virtual/jpeg:0
+ x11-libs/libX11
+ kipi? ( $(add_kdeapps_dep libkipi) )
+ semantic-desktop? ( $(add_kdebase_dep baloo) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with kipi)
+ )
+ # Workaround for bug #479510
+ if [[ -e ${EPREFIX}/usr/include/${CHOST}/jconfig.h ]]; then
+ mycmakeargs+=( -DJCONFIG_H="${EPREFIX}/usr/include/${CHOST}/jconfig.h" )
+ fi
+
+ if use semantic-desktop; then
+ mycmakeargs+=(-DGWENVIEW_SEMANTICINFO_BACKEND=Baloo)
+ else
+ mycmakeargs+=(-DGWENVIEW_SEMANTICINFO_BACKEND=None)
+ fi
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! has_version kde-apps/svgpart:${SLOT} ; then
+ elog "For SVG support, install kde-apps/svgpart:${SLOT}"
+ fi
+
+ if use kipi && ! has_version media-plugins/kipi-plugins ; then
+ elog "The plugins for the KIPI inteface can be found in media-plugins/kipi-plugins"
+ fi
+}
diff --git a/kde-apps/gwenview/metadata.xml b/kde-apps/gwenview/metadata.xml
new file mode 100644
index 000000000000..e4d75d9368b0
--- /dev/null
+++ b/kde-apps/gwenview/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="kipi">Support for the KDE Image Plugin Interface.</flag>
+ </use>
+ <herd>kde</herd>
+</pkgmetadata>