summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-12 19:24:29 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-12 19:24:41 +0100
commit2066cf7b5a1da5ded50affbdc96467b431140f3e (patch)
treeeec619c4a351b2aa2376ea6f0d543086f9b9c747 /kde-apps/analitza/analitza-16.12.1.ebuild
parentdev-python/bandit: bup (diff)
downloadgentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.tar.gz
gentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.tar.bz2
gentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.zip
kde-apps: Version bump KDE Applications 16.12.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/analitza/analitza-16.12.1.ebuild')
-rw-r--r--kde-apps/analitza/analitza-16.12.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/kde-apps/analitza/analitza-16.12.1.ebuild b/kde-apps/analitza/analitza-16.12.1.ebuild
new file mode 100644
index 000000000000..d24e3a8ef923
--- /dev/null
+++ b/kde-apps/analitza/analitza-16.12.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="forceoptional-recursive"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE library for mathematical features"
+KEYWORDS="~amd64 ~x86"
+IUSE="eigen opengl"
+
+DEPEND="
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ eigen? ( dev-cpp/eigen:3 )
+ opengl? (
+ $(add_qt_dep qtopengl)
+ virtual/opengl
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Nothing is installed
+ sed -i \
+ -e "/add_subdirectory(examples)/ s/^/#DONT/" \
+ analitzaplot/CMakeLists.txt || die
+
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package eigen Eigen3)
+ $(cmake-utils_use_find_package opengl OpenGL)
+ )
+
+ kde5_src_configure
+}