summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-10-03 01:03:14 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-10-03 01:11:18 -0400
commita01e73b9ff9e6fbf0926c50d7e8e7940e0bc829c (patch)
tree22cdd09cd7edce63919b454a49485a25627d30f2 /gui-libs
parentdev-debug/valgrind: Stabilize 3.23.0_p3 ppc, #938727 (diff)
downloadgentoo-a01e73b9ff9e6fbf0926c50d7e8e7940e0bc829c.tar.gz
gentoo-a01e73b9ff9e6fbf0926c50d7e8e7940e0bc829c.tar.bz2
gentoo-a01e73b9ff9e6fbf0926c50d7e8e7940e0bc829c.zip
gui-libs/egl-wayland: add 1.1.17_pre20240924
For testing explicit sync, has a lot of fixes over 1.1.16 but release is taking a while and it makes it difficult to know if issues are in egl-wayland or individual software when testing meanwhile. >=1.1.16 is still masked either way, odds are will remain that way until nvidia-drivers ships with >=1.1.16 (currently doesn't) and 1.1.17 is released. Can drop src_install given it ships its own icd json file now. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/egl-wayland/Manifest1
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.17_pre20240924.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/gui-libs/egl-wayland/Manifest b/gui-libs/egl-wayland/Manifest
index 7d90b2ea9043..dee982f4e58b 100644
--- a/gui-libs/egl-wayland/Manifest
+++ b/gui-libs/egl-wayland/Manifest
@@ -1,2 +1,3 @@
DIST egl-wayland-1.1.13.1.tar.gz 68181 BLAKE2B 12587c24828570b5ad399042bb339b27c4d17e14896398d331970b32020956f12d56155e6b97f82c0e7c5f7aa5ad962b923c37ff1609f5384a99bb83e02c2dd7 SHA512 264373b22bab2a26dcd8391308ae24c0afe31168c318fd8fdf74a9958bc41658f9295645c4d91e395b5ab472cdf9dcf5160c448ba54e0aa8eccf04c294ffdb5b
DIST egl-wayland-1.1.16.tar.gz 74615 BLAKE2B ebb6c5ca00bcf78a2d09bc555da8023c16d340c0793b92833fbcc2b05de5a92e26bc59391af9b42d9ed079290c19e94897cf925bc92a926bd518aa3c1a3ccd38 SHA512 cd32f565c287808ebc9999c46650aecbd023d2df6e1824d30c58822e2f93fe807b37eb87c4626b0874797ad61cfcc75a436f528ec7947dd98c5bae24ca6e7a28
+DIST egl-wayland-1.1.17_pre20240924.tar.gz 75212 BLAKE2B 770b806bb7096d90753648d5f166693e47ebec1c6e0a3c883d85ac51a05344318e8f1ed252b09814746873dd6333f06cc1d109012e38005f86b38d503fd14a82 SHA512 f4517c409100596b9c65a8dc0d3b87c896b664a1f7ea9019fb2f4b40043d7fe38ab8f867292914851f4822e0554700ad67d270fea97fc870b7e720f68940a193
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.17_pre20240924.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.17_pre20240924.ebuild
new file mode 100644
index 000000000000..9063308be5d3
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.17_pre20240924.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+HASH_EGLWAYLAND=c10c5300483a8ec975e64e5d76c0fb00ac94e026
+
+DESCRIPTION="EGLStream-based Wayland external platform"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland/"
+SRC_URI="
+ https://github.com/NVIDIA/egl-wayland/archive/${HASH_EGLWAYLAND}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${PN}-${HASH_EGLWAYLAND}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-libs/wayland[${MULTILIB_USEDEP}]
+ x11-libs/libdrm[${MULTILIB_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+ >=gui-libs/eglexternalplatform-1.1-r1
+ media-libs/libglvnd
+"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.6-remove-werror.patch
+)