summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-03 22:12:34 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-03 22:45:48 -0400
commitfb9efe919463d7d6233e409fd5b6d8249fd6dc2e (patch)
tree5f63a242501c21adb25896eb6d01eacf29645039 /gui-libs/eglexternalplatform
parentnet-im/telegram-desktop: Bump to 5.4.1 (diff)
downloadgentoo-fb9efe919463d7d6233e409fd5b6d8249fd6dc2e.tar.gz
gentoo-fb9efe919463d7d6233e409fd5b6d8249fd6dc2e.tar.bz2
gentoo-fb9efe919463d7d6233e409fd5b6d8249fd6dc2e.zip
gui-libs/eglexternalplatform: add 1.2
The new meson.build changes the header install location to /usr/include rather than /usr/include/EGL but should be harmless given the old .pc file was adding -I/usr/include/EGL and egl-gbm/wayland are not using EGL/ in #include statements. Currently unclear if this version is safe to use with <nvidia-560, I believe it only adds access to a new function and it shouldn't matter if it is not used (yet). Did give it a quick try but may have been insufficient to expose issues. Upstream commit message: With version 1.2 (supported starting in 560 series drivers), platform libraries can safely call into the driver during unloadEGLExternalPlatform. Prior to that, the driver would have torn down the internal EGLDisplays by that point. Ultimately 560 is due to replace 550 as the stable driver, and old versions bare 470 (w/o USE=wayland anyway) are due for eventual removal. So *eventual* usage may be a non-issue. If need to check for driver version on this package, may need a subslot to force rebuilds when driver version changes, hopefully can avoid. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-libs/eglexternalplatform')
-rw-r--r--gui-libs/eglexternalplatform/Manifest1
-rw-r--r--gui-libs/eglexternalplatform/eglexternalplatform-1.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/gui-libs/eglexternalplatform/Manifest b/gui-libs/eglexternalplatform/Manifest
index 34147eb40e33..c52a50f670e2 100644
--- a/gui-libs/eglexternalplatform/Manifest
+++ b/gui-libs/eglexternalplatform/Manifest
@@ -1 +1,2 @@
DIST eglexternalplatform-1.1.tar.gz 10372 BLAKE2B f18bd0c5244da34343b3bde8451602b8071972d33139ab4839e7bf68eae6be5fa69a12d5059b4b259bc4eac2e97f46d4d5fa734d48e45b6a6ae69251af86cdf0 SHA512 ee72c928abac060e28515807975a371d3792acd119fa9f9da926ae32105e1e528df8d9a3db57ffac0587b115293ede44997606d9da8e20e7f7061a01dd502748
+DIST eglexternalplatform-1.2.tar.gz 10580 BLAKE2B b3e4971fb7c4496d47c3fef823e1eea32cd6e2f49532a57fcd928c14ccd57a00dcc73b51894ece7651b797a50d6b330d1ecbff1d9a315f80e434f58336266a7d SHA512 7beb43db84320ab9533c2eed4850f8d824cf9b92051e62e33df1cd4fe86f9081377471e0e73146205c136d891d1fdff7b52600b7f63363aee45f6a3c137e9886
diff --git a/gui-libs/eglexternalplatform/eglexternalplatform-1.2.ebuild b/gui-libs/eglexternalplatform/eglexternalplatform-1.2.ebuild
new file mode 100644
index 000000000000..ed2b3aba9691
--- /dev/null
+++ b/gui-libs/eglexternalplatform/eglexternalplatform-1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="EGL External Platform interface"
+HOMEPAGE="https://github.com/NVIDIA/eglexternalplatform/"
+SRC_URI="
+ https://github.com/NVIDIA/eglexternalplatform/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+src_install() {
+ meson_src_install
+
+ # header-only and we need it found for both 32bit and 64bit
+ mv -- "${ED}"/usr/{$(get_libdir),share}/pkgconfig || die
+}