summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-12-17 21:51:10 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-17 21:51:10 +0200
commit0adf9394d4441920a0f24706dc452ea597694ae1 (patch)
tree6eaf1d1477a6af3367f4f2c2c637821217a1c755 /gui-apps
parentdev-util/codespell: add 2.2.6 (diff)
downloadgentoo-0adf9394d4441920a0f24706dc452ea597694ae1.tar.gz
gentoo-0adf9394d4441920a0f24706dc452ea597694ae1.tar.bz2
gentoo-0adf9394d4441920a0f24706dc452ea597694ae1.zip
gui-apps/slurp: add 1.5.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/slurp/Manifest1
-rw-r--r--gui-apps/slurp/slurp-1.5.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/gui-apps/slurp/Manifest b/gui-apps/slurp/Manifest
index 36a252d948f6..e2e2c65d0ce6 100644
--- a/gui-apps/slurp/Manifest
+++ b/gui-apps/slurp/Manifest
@@ -1 +1,2 @@
DIST slurp-1.4.0.tar.gz 18575 BLAKE2B b54a5fe34f35a6a4eefe021a5d5919ae6369c24cfe4906e13ddaf7abc173fad4dc184b211bbadcd09a2a20768e91bbc7199d5e1f29287e9f3fd49b58b294d747 SHA512 deabdc77890a3078d977533318aad6aff9478e32c95e7968483b82534bd52055dce11a531132212ac8966097dad9c6c5e7ad520a374ace85d0ec713df1505d5a
+DIST slurp-1.5.0.tar.gz 18790 BLAKE2B 8d2fd5274bed2d552dc5a3d1359927467120f82840e636d835f48b12a04a2c170df79fe3979d82e0a48fd5e082cd874cfba82251e6054c1323745b48a28b19c0 SHA512 77c4efdaa4ac411f43c598e5d654bcf61f969a5e403df6110757a7b217e02d55d0ba797729e42f8219d3bba79f58bcb36746799de765d3b25f301bf9ac3c1888
diff --git a/gui-apps/slurp/slurp-1.5.0.ebuild b/gui-apps/slurp/slurp-1.5.0.ebuild
new file mode 100644
index 000000000000..8ae614fe07fa
--- /dev/null
+++ b/gui-apps/slurp/slurp-1.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Select a region in a Wayland compositor and print it to the standard output"
+HOMEPAGE="https://github.com/emersion/slurp"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ )
+ meson_src_configure
+}