summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnustep-apps/cenon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnustep-apps/cenon')
-rw-r--r--gnustep-apps/cenon/Manifest3
-rw-r--r--gnustep-apps/cenon/cenon-3.9.5.ebuild23
-rw-r--r--gnustep-apps/cenon/cenon-3.9.6.ebuild24
-rw-r--r--gnustep-apps/cenon/cenon-4.0.2-r1.ebuild27
-rw-r--r--gnustep-apps/cenon/cenon-4.0.2.ebuild24
-rw-r--r--gnustep-apps/cenon/files/cenon-3.9.4-install.patch18
-rw-r--r--gnustep-apps/cenon/files/cenon-3.9.6-gcc47.patch11
-rw-r--r--gnustep-apps/cenon/files/cenon-4.0.2-check-return-value.patch40
-rw-r--r--gnustep-apps/cenon/files/cenon-4.0.2-gnustep-gui-0.24-support.patch231
-rw-r--r--gnustep-apps/cenon/files/cenon-4.0.2-install.patch19
-rw-r--r--gnustep-apps/cenon/metadata.xml10
11 files changed, 430 insertions, 0 deletions
diff --git a/gnustep-apps/cenon/Manifest b/gnustep-apps/cenon/Manifest
new file mode 100644
index 000000000000..346529afbb7d
--- /dev/null
+++ b/gnustep-apps/cenon/Manifest
@@ -0,0 +1,3 @@
+DIST Cenon-3.9.5.tar.bz2 2003607 SHA256 523049066f88e9e022127c017633b0431a29b9eda847e875c8c82d1f976f4977
+DIST Cenon-3.9.6.tar.bz2 2005991 SHA256 373e6c3b7e23950aef865cc3719eece97e1bfbfcecae901cac2e5e6e6ff9175d SHA512 28becfdefe52ffabf36cedf45c9abd409d1f603bf9bf8e75c1637625b368707812c62408c8369a809359ed8977afa98d7eee1b3348de1e3ab9e485e59f853d45 WHIRLPOOL 91eaf7a86d4d2431a6e24c24490677c9c35c9e25fb15e99dec6262183cd9d2ee7b2818b934b8612b5b759628f545f77c8a6687231cb2033d3f4d512e582bf1fe
+DIST Cenon-4.0.2.tar.bz2 4143462 SHA256 8c8906225e188747bf80499886c289786ffc27c6e051dafe12567542f9ef0693 SHA512 202532242eedaf936a35e5df176cf613afe22880f1341e6e9b054fdae9d9aa158acf67bc6927cbbe70cc6215be378e08e318c66ff6a28122676c3ca5b9950d72 WHIRLPOOL 379aab9dba8cc1f9c91d6721168b1f0bc88a8cc646af5ed8437cf2ec589c2b7cf6150782063ced6457ca0b06296721b5a412332b33f3e47254760ac195e65189
diff --git a/gnustep-apps/cenon/cenon-3.9.5.ebuild b/gnustep-apps/cenon/cenon-3.9.5.ebuild
new file mode 100644
index 000000000000..7ea4e2a7b465
--- /dev/null
+++ b/gnustep-apps/cenon/cenon-3.9.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnustep-2
+
+S=${WORKDIR}/${PN/c/C}
+
+DESCRIPTION="Cenon is a vector graphics tool for GNUstep, OpenStep and MacOSX"
+HOMEPAGE="http://www.cenon.info/"
+SRC_URI="http://www.vhf-group.com/vhf-interservice/download/source/${P/c/C}.tar.bz2"
+KEYWORDS="amd64 ppc x86"
+SLOT="0"
+LICENSE="Cenon"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=gnustep-libs/cenonlibrary-3.9.0"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.9.4-install.patch
+}
diff --git a/gnustep-apps/cenon/cenon-3.9.6.ebuild b/gnustep-apps/cenon/cenon-3.9.6.ebuild
new file mode 100644
index 000000000000..c9d888ef4cd5
--- /dev/null
+++ b/gnustep-apps/cenon/cenon-3.9.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnustep-2
+
+S=${WORKDIR}/${PN/c/C}
+
+DESCRIPTION="Cenon is a vector graphics tool for GNUstep, OpenStep and MacOSX"
+HOMEPAGE="http://www.cenon.info/"
+SRC_URI="http://www.vhf-group.com/vhf-interservice/download/source/${P/c/C}.tar.bz2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="Cenon"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=gnustep-libs/cenonlibrary-3.9.0"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.9.4-install.patch
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+}
diff --git a/gnustep-apps/cenon/cenon-4.0.2-r1.ebuild b/gnustep-apps/cenon/cenon-4.0.2-r1.ebuild
new file mode 100644
index 000000000000..cf99ddc08beb
--- /dev/null
+++ b/gnustep-apps/cenon/cenon-4.0.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnustep-2
+
+S=${WORKDIR}/${PN/c/C}
+
+DESCRIPTION="Cenon is a vector graphics tool for GNUstep, OpenStep and MacOSX"
+HOMEPAGE="http://www.cenon.info/"
+SRC_URI="http://www.vhf-group.com/vhf-interservice/download/source/${P/c/C}.tar.bz2"
+KEYWORDS="amd64 ppc x86"
+SLOT="0"
+LICENSE="Cenon"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=gnustep-libs/cenonlibrary-4.0.0"
+
+src_prepare() {
+ # Do not install files already provided by cenonlibrary
+ epatch "${FILESDIR}"/${P}-install.patch
+
+ epatch "${FILESDIR}"/${P}-check-return-value.patch
+ epatch "${FILESDIR}"/${P}-gnustep-gui-0.24-support.patch
+}
diff --git a/gnustep-apps/cenon/cenon-4.0.2.ebuild b/gnustep-apps/cenon/cenon-4.0.2.ebuild
new file mode 100644
index 000000000000..db8be0b40f95
--- /dev/null
+++ b/gnustep-apps/cenon/cenon-4.0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnustep-2
+
+S=${WORKDIR}/${PN/c/C}
+
+DESCRIPTION="Cenon is a vector graphics tool for GNUstep, OpenStep and MacOSX"
+HOMEPAGE="http://www.cenon.info/"
+SRC_URI="http://www.vhf-group.com/vhf-interservice/download/source/${P/c/C}.tar.bz2"
+KEYWORDS="amd64 ppc x86"
+SLOT="0"
+LICENSE="Cenon"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=gnustep-libs/cenonlibrary-4.0.0"
+
+src_prepare() {
+ # Do not install files already provided by cenonlibrary
+ epatch "${FILESDIR}"/${P}-install.patch
+}
diff --git a/gnustep-apps/cenon/files/cenon-3.9.4-install.patch b/gnustep-apps/cenon/files/cenon-3.9.4-install.patch
new file mode 100644
index 000000000000..45540fab7b01
--- /dev/null
+++ b/gnustep-apps/cenon/files/cenon-3.9.4-install.patch
@@ -0,0 +1,18 @@
+diff -Naur Cenon.orig/GNUmakefile.postamble Cenon/GNUmakefile.postamble
+--- Cenon.orig/GNUmakefile.postamble 2010-09-01 13:50:38.355743781 +0200
++++ Cenon/GNUmakefile.postamble 2010-09-01 13:51:40.542612032 +0200
+@@ -18,13 +18,7 @@
+ # before-install::
+
+ # Things to do after installing
+-after-install::
+- # copy library
+- #rm -R $(GNUSTEP_LOCAL_LIBRARY)/$(APP_NAME)
+- cp -R Library/$(APP_NAME)/ $(GNUSTEP_LOCAL_LIBRARY)/
+- # set permissions (rrr)
+- chmod -R ugo+rX $(GNUSTEP_LOCAL_APPS)/$(APP_NAME).*
+- #chmod -R ugo+rX $(GNUSTEP_LOCAL_LIBRARY)/$(APP_NAME)
++#after-install::
+
+ # Things to do before uninstalling
+ # before-uninstall::
diff --git a/gnustep-apps/cenon/files/cenon-3.9.6-gcc47.patch b/gnustep-apps/cenon/files/cenon-3.9.6-gcc47.patch
new file mode 100644
index 000000000000..662a8ea5ca70
--- /dev/null
+++ b/gnustep-apps/cenon/files/cenon-3.9.6-gcc47.patch
@@ -0,0 +1,11 @@
+--- cenon.app-3.93.orig/VHFShared/vhfCompatibility.h
++++ cenon.app-3.93/VHFShared/vhfCompatibility.h
+@@ -44,7 +44,7 @@
+ #if defined( GNUSTEP_BASE_VERSION )
+
+ # define VHFIsDrawingToScreen() [[NSGraphicsContext currentContext] isDrawingToScreen]
+-# define VHFSelectorIsEqual(a, b) sel_eq(a, b)
++# define VHFSelectorIsEqual(a, b) sel_isEqual(a, b)
+ # define VHFAntialiasing() [[NSGraphicsContext currentContext] shouldAntialias]
+ # define VHFSetAntialiasing(f) [[NSGraphicsContext currentContext] setShouldAntialias:f]
+ # define PSWait() [[NSGraphicsContext currentContext] flushGraphics]
diff --git a/gnustep-apps/cenon/files/cenon-4.0.2-check-return-value.patch b/gnustep-apps/cenon/files/cenon-4.0.2-check-return-value.patch
new file mode 100644
index 000000000000..a23135b3230d
--- /dev/null
+++ b/gnustep-apps/cenon/files/cenon-4.0.2-check-return-value.patch
@@ -0,0 +1,40 @@
+Description: Check the return value of `system'.
+Author: Yavor Doganov <yavor@gnu.org>
+Forwarded: yes
+Last-Update: 2014-06-25
+---
+
+--- cenon.app.orig/VHFImport/PSImport.m
++++ cenon.app/VHFImport/PSImport.m
+@@ -143,7 +143,14 @@
+
+ /* convert pdf to eps */
+ commandLine = [NSString stringWithFormat:@"%@ -q -dNOPAUSE -dBATCH -dSAFER -sDEVICE=epswrite -sOutputFile=%@ -c save pop -f '%@'", [self gsPath], psFile, pdfFile];
+- system([commandLine UTF8String]);
++ if (system([commandLine UTF8String]) != 0)
++ {
++ NSRunAlertPanel(@"Unable to import file",
++ @"An error occured while importing the file.\n"
++ @"Make sure you have ghostscript installed in PATH.",
++ @"OK", nil, nil);
++ return nil;
++ }
+
+ /* import ps */
+ psData = [NSData dataWithContentsOfFile:psFile];
+@@ -330,7 +337,14 @@
+ //[data writeToFile:inFile atomically:NO]; // <= 10.4
+
+ commandLine = [NSString stringWithFormat:@"%@ -dNODISPLAY -dBATCH -dNOSAFER -g1000x1000 '%@'", [self gsPath], inFile];
+- system([commandLine UTF8String]);
++ if (system([commandLine UTF8String]) != 0)
++ {
++ NSRunAlertPanel(@"Unable to import file",
++ @"An error occured while importing the file.\n"
++ @"Make sure you have ghostscript installed in PATH.",
++ @"OK", nil, nil);
++ return nil;
++ }
+
+ /* load generated file */
+ //data = [[[NSString alloc] initWithContentsOfFile:outFile] autorelease];
diff --git a/gnustep-apps/cenon/files/cenon-4.0.2-gnustep-gui-0.24-support.patch b/gnustep-apps/cenon/files/cenon-4.0.2-gnustep-gui-0.24-support.patch
new file mode 100644
index 000000000000..b0799d835175
--- /dev/null
+++ b/gnustep-apps/cenon/files/cenon-4.0.2-gnustep-gui-0.24-support.patch
@@ -0,0 +1,231 @@
+Description: Various fixes for gnustep-base/1.24 and gnustep-gui/0.24.
+ - Proper intialization.
+ - Use correct return types for methods and compare functions.
+ - Likewise for method arguments.
+ - Avoid conflicting methods by declaring the ivars of a specific type.
+ - Add mising argument to private method declaration.
+Author: Yavor Doganov <yavor@gnu.org>
+Bug-Debian: http://bugs.debian.org/749553
+Forwarded: yes
+Last-Update: 2014-06-25
+---
+
+--- cenon.app.orig/GraphicObjects.subproj/VCurveFit.m
++++ cenon.app/GraphicObjects.subproj/VCurveFit.m
+@@ -87,7 +87,7 @@
+ /* turn lines into optimized curves
+ */
+ - (VPath*)fitGraphic:(VGraphic*)g maxError:(double)maxError
+-{ Point2 *pts = nil;
++{ Point2 *pts = NULL;
+ int i, nPts = 0;
+ VPath *path = nil;
+
+--- cenon.app.orig/GraphicObjects.subproj/VGroup.h
++++ cenon.app/GraphicObjects.subproj/VGroup.h
+@@ -67,7 +67,7 @@
+ - (float)stepWidth;
+ - (void)setRadialCenter:(NSPoint)rc;
+ - (NSPoint)radialCenter;
+-- (void)setList:(NSArray*)aList;
++- (void)setList:(NSMutableArray*)aList;
+ - (void)addObject:(VGraphic*)g;
+ - (void)add:(NSArray*)addList;
+ - (NSMutableArray*)list;
+--- cenon.app.orig/InspectorPanel.subproj/IPAllAcc.h
++++ cenon.app/InspectorPanel.subproj/IPAllAcc.h
+@@ -40,7 +40,7 @@
+
+ @interface IPAllAcc:IPBasicLevel
+ {
+- id accPopup; // the popup to allow the user to select the different accessories
++ NSPopUpButton *accPopup; // the popup to allow the user to select the different accessories
+ id accView; // the view containing the accessory view
+
+ int levelCnt; // number of accessories
+--- cenon.app.orig/InspectorPanel.subproj/IPAllFilling.h
++++ cenon.app/InspectorPanel.subproj/IPAllFilling.h
+@@ -39,7 +39,7 @@
+ id stepForm;
+ id colorWell;
+ id colorWellGraduated;
+- id fillPopup;
++ NSPopUpButton *fillPopup;
+ id sliderBox;
+ id radialCenterText;
+ id angleButtonLeft;
+--- cenon.app.orig/InspectorPanel.subproj/IPAllStrokeWidth.h
++++ cenon.app/InspectorPanel.subproj/IPAllStrokeWidth.h
+@@ -35,7 +35,7 @@
+ @interface IPAllStrokeWidth:IPBasicLevel
+ {
+ int stroked;
+- id strokePopup;
++ NSPopUpButton *strokePopup;
+ id colorWell;
+ id widthField;
+ id widthSlider;
+--- cenon.app.orig/LayerObject.h
++++ cenon.app/LayerObject.h
+@@ -144,8 +144,8 @@
+ - (void)setString:(NSString *)aString;
+ - (NSString*)string;
+
+-- (void)setTag:(int)newTag;
+-- (int)tag;
++- (void)setTag:(NSInteger)newTag;
++- (NSInteger)tag;
+
+ - (void)setColor:(NSColor *)aColor;
+ - (NSColor *)color;
+--- cenon.app.orig/LayerObject.m
++++ cenon.app/LayerObject.m
+@@ -227,8 +227,8 @@
+ - (void)setString:(NSString *)aString { [string release]; string = [aString retain]; }
+ - (NSString *)string { return string; }
+
+-- (void)setTag:(int)newTag { tag = newTag; }
+-- (int)tag { return tag; }
++- (void)setTag:(NSInteger)newTag { tag = newTag; }
++- (NSInteger)tag { return tag; }
+
+ - (void)setColor:(NSColor *)aColor { color=aColor; }
+ - (NSColor *)color { return color; }
+--- cenon.app.orig/GraphicObjects.subproj/VPath.h
++++ cenon.app/GraphicObjects.subproj/VPath.h
+@@ -58,7 +58,7 @@
+ - (NSMutableArray*)list;
+ - (void)setList:aList;
+ - (void)setList:aList optimize:(BOOL)optimize;
+-- (unsigned)count;
++- (NSUInteger)count;
+ - (unsigned)countRecursive;
+ - (void)getEndPoints:(NSPoint*)p1 :(NSPoint*)p2;
+ - (int)selectedKnobIndex;
+--- cenon.app.orig/GraphicObjects.subproj/VPath.m
++++ cenon.app/GraphicObjects.subproj/VPath.m
+@@ -399,7 +399,7 @@
+ *p2 = [[list objectAtIndex:[list count]-1] pointWithNum:MAXINT];
+ }
+
+-- (unsigned)count
++- (NSUInteger)count
+ {
+ return [list count];
+ }
+--- cenon.app.orig/InspectorPanel.subproj/IPImage.h
++++ cenon.app/InspectorPanel.subproj/IPImage.h
+@@ -43,7 +43,7 @@
+ id thumbSwitch;
+ id nameField;
+ id factorField;
+- id compPopUp;
++ NSPopUpButton *compPopUp;
+
+ VGraphic *graphic; // the loaded graphic or the first of them if multiple
+ }
+--- cenon.app.orig/DINImportSub.m
++++ cenon.app/DINImportSub.m
+@@ -46,7 +46,7 @@
+ /* created: 2001-06-06
+ * performcance map is not used, because we set this later when the layers are added to the view!
+ */
+-static NSInteger sortLayer(id l1, id l2, void *context)
++static NSComparisonResult sortLayer(id l1, id l2, void *context)
+ { float d1 = 0.0, d2 = 0.0;
+ VGraphic *g0 = [[l1 list] objectAtIndex:0], *g1 = [[l2 list] objectAtIndex:0];
+
+--- cenon.app.orig/DocView.m
++++ cenon.app/DocView.m
+@@ -994,7 +994,7 @@
+ #define SORT_COL_LRUL 5
+ #define SORT_ROW_URLL 6
+ #define SORT_ROW_LRUL 7
+-NSInteger sortPosition(id g1, id g2, void *context)
++NSComparisonResult sortPosition(id g1, id g2, void *context)
+ { NSPoint p1 = [g1 bounds].origin, p2 = [g2 bounds].origin;
+ int sort = *(int*)context;
+
+--- cenon.app.orig/SVGImportSub.m
++++ cenon.app/SVGImportSub.m
+@@ -112,7 +112,7 @@
+ /* allocate a group object
+ * copy the objects in aList to the group, add the group to bList
+ */
+-- (void)addGroupList:(NSArray*)aList toList:bList
++- (void)addGroupList:(NSMutableArray*)aList toList:bList
+ { VGroup *g = [VGroup group];
+ int i;
+ NSMutableArray *mutArray = [NSMutableArray array];
+@@ -136,7 +136,7 @@
+ [bList addObject:g];
+ }
+
+-- (void)addGroupList:(NSArray*)aList toList:bList withTransform:(NSAffineTransform*)matrix
++- (void)addGroupList:(NSMutableArray*)aList toList:bList withTransform:(NSAffineTransform*)matrix
+ { VGroup *g = [VGroup group];
+ int i;
+ NSMutableArray *mutArray = [NSMutableArray array];
+--- cenon.app.orig/MoveCell.h
++++ cenon.app/MoveCell.h
+@@ -32,7 +32,7 @@
+
+ @interface MoveCell:NSCell
+ {
+- int tag;
++ NSInteger tag;
+ MoveMatrix *moveMatrix;
+
+ float ascender, descender, lineHeight;
+@@ -41,8 +41,8 @@
+ - (void)setMatrix:(MoveMatrix *)anMatrix;
+ - (void)setFont:(NSFont *)fontObj;
+
+-- (void)setTag:(int)anInt;
+-- (int)tag;
++- (void)setTag:(NSInteger)anInt;
++- (NSInteger)tag;
+
+ - (BOOL)dependant;
+
+--- cenon.app.orig/MoveCell.m
++++ cenon.app/MoveCell.m
+@@ -39,14 +39,14 @@
+
+ /* modified: 13.01.93
+ */
+-- (void)setTag:(int)anInt
++- (void)setTag:(NSInteger)anInt
+ {
+ tag=anInt;
+ }
+
+ /* modified: 13.01.93
+ */
+-- (int)tag
++- (NSInteger)tag
+ {
+ return tag;
+ }
+--- cenon.app.orig/VHFImport/DXFImport.m
++++ cenon.app/VHFImport/DXFImport.m
+@@ -86,7 +86,7 @@
+ - (BOOL)getSolid:(NSScanner*)scanner :(NSPoint*)ps :(int*)pCnt;
+ - (BOOL)getCircle:(NSScanner*)scanner :(NSPoint*)ctr :(NSPoint*)start :(float*)angle;
+ - (BOOL)getArc:(NSScanner*)scanner :(NSPoint*)ctr :(NSPoint*)start :(float*)angle;
+-- (BOOL)getText :(NSScanner*)scanner mtext:(BOOL)mext :(NSString**)string :(float*)angle :(NSPoint*)origin :(float*)size :(float*)ar :(int*)alignment;
++- (BOOL)getText :(NSScanner*)scanner mtext:(BOOL)mext :(NSString**)string :(float*)angle :(NSPoint*)origin :(float*)size :(float*)ar :(int*)alignment :(NSString**)fontName;
+ - (BOOL)get3DFace:(NSScanner*)scanner points:(V3Point*)pts color:(NSColor**)color;
+ - (BOOL)getInsert:(NSScanner*)scanner :cList;
+ - (void)updateBounds:(NSPoint)p;
+--- cenon.app.orig/TileScrollView.h
++++ cenon.app/TileScrollView.h
+@@ -36,7 +36,7 @@
+ @interface TileScrollView:NSScrollView
+ {
+ id box;
+- id resPopupListButton;
++ NSPopUpButton *resPopupListButton;
+ id document;
+ VFloat oldScaleFactor;
+ }
diff --git a/gnustep-apps/cenon/files/cenon-4.0.2-install.patch b/gnustep-apps/cenon/files/cenon-4.0.2-install.patch
new file mode 100644
index 000000000000..8a75db6ee13a
--- /dev/null
+++ b/gnustep-apps/cenon/files/cenon-4.0.2-install.patch
@@ -0,0 +1,19 @@
+diff -Naur Cenon.orig/GNUmakefile.postamble Cenon/GNUmakefile.postamble
+--- Cenon.orig/GNUmakefile.postamble 2013-04-23 18:18:19.231871028 +0200
++++ Cenon/GNUmakefile.postamble 2013-04-23 18:19:31.482864370 +0200
+@@ -18,12 +18,12 @@
+ # before-install::
+
+ # Things to do after installing
+-after-install::
++#after-install::
+ # copy library
+ #rm -R $(GNUSTEP_LIBRARY)/$(APP_NAME)
+- cp -R Library/$(APP_NAME)/ $(GNUSTEP_LIBRARY)/
++ #cp -R Library/$(APP_NAME)/ $(GNUSTEP_LIBRARY)/
+ # set permissions (rrr)
+- chmod -R ugo+rX $(GNUSTEP_APPS)/$(APP_NAME).*
++ #chmod -R ugo+rX $(GNUSTEP_APPS)/$(APP_NAME).*
+ #chmod -R ugo+rX $(GNUSTEP_LIBRARY)/$(APP_NAME)
+
+ # Things to do before uninstalling
diff --git a/gnustep-apps/cenon/metadata.xml b/gnustep-apps/cenon/metadata.xml
new file mode 100644
index 000000000000..d09e0e070493
--- /dev/null
+++ b/gnustep-apps/cenon/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnustep</herd>
+ <longdescription>
+ Cenon is a graphical tool of a special kind. Build upon a
+ modular graphical core, Cenon offers a wide variety of
+ possibilities and applications.
+ </longdescription>
+</pkgmetadata>