summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-21 17:08:14 +0000
committerSam James <sam@gentoo.org>2022-01-21 17:08:14 +0000
commit8d51833f1b370bb001874f7e92590ad54a64f90c (patch)
tree817915b269e307500c165f7bd2ab91eb1ea612ee /gnome-extra
parentmedia-gfx/gnome-screenshot: fix build with meson 0.61 (diff)
downloadgentoo-8d51833f1b370bb001874f7e92590ad54a64f90c.tar.gz
gentoo-8d51833f1b370bb001874f7e92590ad54a64f90c.tar.bz2
gentoo-8d51833f1b370bb001874f7e92590ad54a64f90c.zip
gnome-extra/gnome-weather: fix build with meson 0.61
Closes: https://bugs.gentoo.org/831749 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-weather/files/gnome-weather-41.0-fix-meson-0.61-build.patch20
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-41.0.ebuild7
2 files changed, 26 insertions, 1 deletions
diff --git a/gnome-extra/gnome-weather/files/gnome-weather-41.0-fix-meson-0.61-build.patch b/gnome-extra/gnome-weather/files/gnome-weather-41.0-fix-meson-0.61-build.patch
new file mode 100644
index 000000000000..6756c77f8b7d
--- /dev/null
+++ b/gnome-extra/gnome-weather/files/gnome-weather-41.0-fix-meson-0.61-build.patch
@@ -0,0 +1,20 @@
+https://gitlab.gnome.org/GNOME/gnome-weather/-/commit/4be71525f07189e97720688472172604879d49a5
+https://bugs.gentoo.org/831749
+
+From: rvalue <i@rvalue.moe>
+Date: Fri, 17 Dec 2021 12:26:42 +0000
+Subject: [PATCH] Remove incorrect args for i18n.merge_file
+
+`i18n.merge_file` has been ignoring positional arguments for a time and
+explicitly rejects with error since meson 0.60.0
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -59,7 +59,6 @@ endif
+ appdata_conf = configuration_data()
+ appdata_conf.set('app_id', weather_id)
+ appdata = i18n.merge_file(
+- 'appdata',
+ input: configure_file(
+ input: '@0@.appdata.xml.in.in'.format(default_id),
+ output: '@0@.appdata.xml.in'.format(default_id),
+GitLab
diff --git a/gnome-extra/gnome-weather/gnome-weather-41.0.ebuild b/gnome-extra/gnome-weather/gnome-weather-41.0.ebuild
index 571ac23d8b64..59f506be80f2 100644
--- a/gnome-extra/gnome-weather/gnome-weather-41.0.ebuild
+++ b/gnome-extra/gnome-weather/gnome-weather-41.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,12 +31,17 @@ BDEPEND="
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"
+
# Tests have a lot of issues, starting with reliance on a system installation,
# accessing the network and other intermittent failures with network-sandbox disabled
# https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
# test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
# With 3.34, this is now behind a dogtail option we can pass (and have data validation)
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-meson-0.61-build.patch
+)
+
src_configure() {
meson_src_configure -Dprofile=default -Ddogtail=false
}