summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-03-01 12:58:49 -0800
committerPatrick McLean <chutzpah@gentoo.org>2024-03-01 12:58:49 -0800
commitcb5e9381f8649fe6207a87e102b909ebe780d707 (patch)
tree09400f952e9e62fe37e5d7b870a789654f39b60e /gnome-extra/nm-applet
parentmeson.eclass: fix setting BUILD_DIR after the lto refactor (diff)
downloadgentoo-cb5e9381f8649fe6207a87e102b909ebe780d707.tar.gz
gentoo-cb5e9381f8649fe6207a87e102b909ebe780d707.tar.bz2
gentoo-cb5e9381f8649fe6207a87e102b909ebe780d707.zip
gnome-extra/nm-applet: add 1.36.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'gnome-extra/nm-applet')
-rw-r--r--gnome-extra/nm-applet/Manifest1
-rw-r--r--gnome-extra/nm-applet/nm-applet-1.36.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/gnome-extra/nm-applet/Manifest b/gnome-extra/nm-applet/Manifest
index 6ad61c0f5d22..87e28204f69e 100644
--- a/gnome-extra/nm-applet/Manifest
+++ b/gnome-extra/nm-applet/Manifest
@@ -1,2 +1,3 @@
DIST network-manager-applet-1.32.0.tar.xz 1899584 BLAKE2B 7ce83c1a81ef62002283b87d09dd7045d3688597f71dba7f91b6feaed504934af10974cbe5732027a187a031df6668697cd433ad4bb5975503b1c7fa6789d6c2 SHA512 a7abe55c88fa95406e62fb442c068f95325fca748438aa037e0bd5b23add6454c3bc27ac54afe520746d32845bc7403f228f9bfde8e70c7442c906a8227ebe6c
DIST network-manager-applet-1.34.0.tar.xz 1981256 BLAKE2B 43056b0e804dec4915664d366399d0ca2bc3621dc94950ebb577676fd5f92075bd82743564ba36a5e4831d2ebcf5b2ff06a3205e9b30303c30d1ac1dec21c56f SHA512 46c3a0496c5c111ad551a3d16b7ade21ad9e2d6c576f9f6da69901a27403730008ba30a577e5efad32265f53b348077224155139f0f00a916a7da7ce7c0a0c00
+DIST network-manager-applet-1.36.0.tar.xz 1923064 BLAKE2B fc9e4a4a83cc84254e1e18abcbea555f0bd3c83706faff769d80308d366cdb4d755a17f616551b461090855975584d6bdddaede5c0dd1863306b7ac64d5bc14e SHA512 081cb1f219b0ea44ff15b9ebb3696d976463530317244ce25b18cdc292d453fccd2619cc42ea07798604ed1e5f7c5295bcb7ba148f1ed3312bf8f80d8647e30a
diff --git a/gnome-extra/nm-applet/nm-applet-1.36.0.ebuild b/gnome-extra/nm-applet/nm-applet-1.36.0.ebuild
new file mode 100644
index 000000000000..a93c6e8e045e
--- /dev/null
+++ b/gnome-extra/nm-applet/nm-applet-1.36.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GNOME_ORG_MODULE="network-manager-applet"
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="NetworkManager connection editor and applet"
+HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="appindicator +modemmanager selinux teamd"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# >=networkmanager-1.46 for ensuring stable-ssid checkbox feature will work
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=app-crypt/libsecret-0.18
+ >=net-libs/libnma-1.10.4-r2
+ >=x11-libs/gtk+-3.10:3
+ >=net-misc/networkmanager-1.46[modemmanager?,teamd?]
+ appindicator? (
+ dev-libs/libayatana-appindicator
+ >=dev-libs/libdbusmenu-16.04.0
+ )
+ modemmanager? ( net-misc/modemmanager )
+ selinux? ( sys-libs/libselinux )
+ teamd? ( >=dev-libs/jansson-2.7:= )
+
+ virtual/freedesktop-icon-theme
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dappindicator=$(usex appindicator ayatana no)
+ $(meson_use modemmanager wwan)
+ $(meson_use selinux)
+ $(meson_use teamd team)
+ -Dmore_asserts=0
+ -Dld_gc=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}