summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2024-06-23 23:45:43 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-04 23:35:45 -0400
commit6d59fbc1943e0c4532801cf1c43d560cbce2455d (patch)
treef18d45c31dd45914bf8277a2dc640b944821aec8 /gnome-extra/cjs
parentgnome-extra/cjs: add 6.2.0 (diff)
downloadgentoo-6d59fbc1943e0c4532801cf1c43d560cbce2455d.tar.gz
gentoo-6d59fbc1943e0c4532801cf1c43d560cbce2455d.tar.bz2
gentoo-6d59fbc1943e0c4532801cf1c43d560cbce2455d.zip
gnome-extra/cjs: drop 5.8.0
Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'gnome-extra/cjs')
-rw-r--r--gnome-extra/cjs/Manifest1
-rw-r--r--gnome-extra/cjs/cjs-5.8.0.ebuild95
-rw-r--r--gnome-extra/cjs/files/cjs-5.8.0-move_have_gtk4_to_the_appropriate_place.patch38
3 files changed, 0 insertions, 134 deletions
diff --git a/gnome-extra/cjs/Manifest b/gnome-extra/cjs/Manifest
index a51b5c6877ba..3e700cf4706e 100644
--- a/gnome-extra/cjs/Manifest
+++ b/gnome-extra/cjs/Manifest
@@ -1,3 +1,2 @@
-DIST cjs-5.8.0.tar.gz 877668 BLAKE2B e4c031631030c2a4221937d5ca04034163f70f21e6e5ff2d0ca15f31a7455e83ecb1f977c4c4fb9a57e58d266856f817446e53b86ee87460bedf5339e33461b6 SHA512 f43bda5810b90ceab24d096d884c65503b2d9b94f5c0a9e6082215a427df97fbec4a21ee3f2d4f22d98ac24a04af1dcd9064600ec191ccec96ae0869cc803a02
DIST cjs-6.0.0.tar.gz 877404 BLAKE2B 4290f0801f715aab1387da2ce0724376912db8ff3ad16fa8ad7eff03538dfc53ecbff2b7df0e70e52d16295b23ce51024da735d0e618b995fd3d3dfe297f9e26 SHA512 4cb359bf817d22a727683fd451ad6bde19aff4409e9033a97ef9cb204b3bd4c5e86421d7c01a267c3b4d42feb9b3bc5effb6fd970b3baf733242868c09536d95
DIST cjs-6.2.0.tar.gz 874457 BLAKE2B 7b1afda55bc0b5da165a20afa7be58382b8f03f1421bde960f6a3f134d7bdb2bdd44320b0b613f4f710258379da6666383a20d92556a1172971ca8340ae6d348 SHA512 5f7ce7f1ba648db834d7703e909ef65cf369d47147ca02e90b8844c31b4360dcc0fb94bbd3265632c3de8ef2b026934dd799b94a2ff3895442a2f9fc469f53db
diff --git a/gnome-extra/cjs/cjs-5.8.0.ebuild b/gnome-extra/cjs/cjs-5.8.0.ebuild
deleted file mode 100644
index 1246cf2ca035..000000000000
--- a/gnome-extra/cjs/cjs-5.8.0.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit flag-o-matic meson pax-utils python-any-r1 virtualx
-
-DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
-HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cjs"
-SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD CC0-1.0 MIT MPL-2.0 || ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
-SLOT="0"
-IUSE="+cairo examples readline sysprof test"
-KEYWORDS="amd64 ~arm64 ~loong ~ppc64 ~riscv x86"
-
-RDEPEND="
- dev-lang/spidermonkey:102
- >=dev-libs/glib-2.66.0:2
- >=dev-libs/gobject-introspection-1.71.0:=
- >=dev-libs/libffi-3.3:0=
-
- cairo? (
- x11-libs/cairo[glib,svg(+),X]
- x11-libs/libX11
- )
- readline? ( sys-libs/readline:0= )
-"
-DEPEND="
- ${RDEPEND}
- sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
- test? (
- sys-apps/dbus
- x11-libs/gtk+:3[introspection]
- )
-"
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.8.0-move_have_gtk4_to_the_appropriate_place.patch
-)
-
-src_prepare() {
- default
- python_fix_shebang build
-}
-
-src_configure() {
- append-cppflags -DG_DISABLE_CAST_CHECKS
-
- # On musl, it's required that either gjs, pixman or gnome-shell to be built
- # with a larger stack otherwise librsvg fails to render a particular SVG, as
- # a result we fail to get gdm or gnome-shell running (greeted with a fail
- # whale screen). The bug has been reported to librsvg. This is ideally just
- # a temporary workaround until we understand what exactly needs a larger
- # stack size, as it's not sufficient to do just librsvg.
- #
- # Please refer to:
- # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
- # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
- #
- # TODO: Find an actual fix instead of increasing the stack
- use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
-
- local emesonargs=(
- $(meson_feature cairo)
- $(meson_feature readline)
- $(meson_feature sysprof profiler)
- -Dinstalled_tests=false
- $(meson_use !test skip_dbus_tests)
- $(meson_use !test skip_gtk_tests)
- )
- meson_src_configure
-}
-
-src_test() {
- virtx meson_src_test
-}
-
-src_install() {
- meson_src_install
-
- if use examples; then
- docinto examples
- dodoc "${S}"/examples/*
- fi
-
- # Required for cjs-console to run correctly on PaX systems
- pax-mark mr "${ED}/usr/bin/cjs-console"
-}
diff --git a/gnome-extra/cjs/files/cjs-5.8.0-move_have_gtk4_to_the_appropriate_place.patch b/gnome-extra/cjs/files/cjs-5.8.0-move_have_gtk4_to_the_appropriate_place.patch
deleted file mode 100644
index 2bb80126507f..000000000000
--- a/gnome-extra/cjs/files/cjs-5.8.0-move_have_gtk4_to_the_appropriate_place.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-# https://gitlab.gnome.org/GNOME/gjs/-/issues/532
-# https://gitlab.gnome.org/GNOME/gjs/-/merge_requests/830/diffs?commit_id=83683d093c157828cf7787e53a32c586ae4e85d3
-diff --git a/installed-tests/js/meson.build b/installed-tests/js/meson.build
-index 6db887d2250face397079b03d215bbd13f455efb..1e953ceb7695356b6e854775e5db005a9c22e053 100644
---- a/installed-tests/js/meson.build
-+++ b/installed-tests/js/meson.build
-@@ -203,9 +203,13 @@ endif
- # during build should be run using dbus-run-session
-
- dbus_tests = ['GDBus']
--if have_gtk4 and not get_option('skip_gtk_tests')
-- # FIXME: find out why GTK4 tries to acquire a message bus
-- dbus_tests += 'Gtk4'
-+if not get_option('skip_gtk_tests')
-+ have_gtk4 = dependency('gtk4', required: false).found()
-+
-+ if have_gtk4
-+ # FIXME: find out why GTK4 tries to acquire a message bus
-+ dbus_tests += 'Gtk4'
-+ endif
- endif
-
- bus_config = files('../../test/test-bus.conf')
-diff --git a/meson.build b/meson.build
-index 3ac372a16b0bfaa364ed7422119f3e6e4af8971e..5c7703935b68c724347692ef5bf47a3edf868c61 100644
---- a/meson.build
-+++ b/meson.build
-@@ -679,10 +679,6 @@ endif
-
- ### Tests and test setups ######################################################
-
--if not get_option('skip_gtk_tests')
-- have_gtk4 = dependency('gtk4', required: false).found()
--endif
--
- subdir('installed-tests')
-
- # Note: The test program in test/ needs to be ported