summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2025-01-01 19:41:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-01 22:52:41 +0100
commit802b4ee4e66147bfca5e58b7fa8a3a6f3c1b0702 (patch)
tree1ef3569af2bc2308847efe69b216d9a7d199a4df /games-util
parentdev-ada/templates-parser: add 25.0.0 (diff)
downloadgentoo-802b4ee4e66147bfca5e58b7fa8a3a6f3c1b0702.tar.gz
gentoo-802b4ee4e66147bfca5e58b7fa8a3a6f3c1b0702.tar.bz2
gentoo-802b4ee4e66147bfca5e58b7fa8a3a6f3c1b0702.zip
games-util/lgogdownloader: Drop IUSE qt6 (make Qt6 unconditional)
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/lgogdownloader/lgogdownloader-3.16-r1.ebuild48
-rw-r--r--games-util/lgogdownloader/lgogdownloader-9999.ebuild3
2 files changed, 50 insertions, 1 deletions
diff --git a/games-util/lgogdownloader/lgogdownloader-3.16-r1.ebuild b/games-util/lgogdownloader/lgogdownloader-3.16-r1.ebuild
new file mode 100644
index 000000000000..384ea18d90ab
--- /dev/null
+++ b/games-util/lgogdownloader/lgogdownloader-3.16-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Unofficial GOG.com downloader for Linux"
+HOMEPAGE="https://sites.google.com/site/gogdownloader/"
+SRC_URI="https://github.com/Sude-/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+RDEPEND="
+ >=app-crypt/rhash-1.3.3-r2:0=
+ app-text/htmltidy:=
+ dev-libs/boost:=[zlib]
+ >=dev-libs/jsoncpp-1.7:0=
+ dev-libs/tinyxml2:0=
+ >=net-misc/curl-7.55:0=[ssl]
+ gui? (
+ dev-qt/qtbase:6[network,widgets]
+ dev-qt/qtwebengine:6[widgets]
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT_GUI=$(usex gui)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ gunzip "${ED}"/usr/share/man/man1/${PN}.1.gz || die
+}
diff --git a/games-util/lgogdownloader/lgogdownloader-9999.ebuild b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
index 653b4c27add5..74f57ee662f9 100644
--- a/games-util/lgogdownloader/lgogdownloader-9999.ebuild
+++ b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,6 +8,7 @@ inherit cmake git-r3
DESCRIPTION="Unofficial GOG.com downloader for Linux"
HOMEPAGE="https://sites.google.com/site/gogdownloader/"
EGIT_REPO_URI="https://github.com/Sude-/lgogdownloader.git"
+
LICENSE="WTFPL-2"
SLOT="0"
IUSE="gui"