summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2025-01-24 00:37:58 -0500
committerIonen Wolkens <ionen@gentoo.org>2025-01-24 02:40:11 -0500
commit66e9ede9942b6887be9b0fe9487cda35e34dedce (patch)
treebc0bc8136735f09646277ee4f6bb568d228ef598 /games-util
parentdev-util/qbs: drop 2.4.2 (diff)
downloadgentoo-66e9ede9942b6887be9b0fe9487cda35e34dedce.tar.gz
gentoo-66e9ede9942b6887be9b0fe9487cda35e34dedce.tar.bz2
gentoo-66e9ede9942b6887be9b0fe9487cda35e34dedce.zip
games-util/xpadneo: drop 0.9.6
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/xpadneo/Manifest1
-rw-r--r--games-util/xpadneo/files/xpadneo-0.9.6-kernel-6.12.patch24
-rw-r--r--games-util/xpadneo/xpadneo-0.9.6.ebuild58
3 files changed, 0 insertions, 83 deletions
diff --git a/games-util/xpadneo/Manifest b/games-util/xpadneo/Manifest
index 8598412b9b7f..9b6e0ef7a37d 100644
--- a/games-util/xpadneo/Manifest
+++ b/games-util/xpadneo/Manifest
@@ -1,2 +1 @@
-DIST xpadneo-0.9.6.tar.gz 1344171 BLAKE2B 22a85732de2894d310e0994c101ed62b7358f1b6b8ba5b389fc273bfd48a1ce619ebc04f3699818290f61833234d4c444fff25ea852d9dcf420b99ab28687a03 SHA512 f423fb89cf911c727917591d79909acaecc9fdb68ca10c5cc2a128bd66174799f3efb2b9a87e43bb315ab92ddb7513f79300f06d347fabc9de11e63fc1d25689
DIST xpadneo-0.9.7.tar.gz 1348791 BLAKE2B 6715e684d046ad3162db65196896d23f0c70046d02adbf5886d849818120fb731acb86da0a9e18e54b56b31220911ea25c296f1b8473eb0f0fca4fe96b98712b SHA512 c5a3438fef6215f3dd733099f8d5fc86b55b092f3d808969040eb38b29c4fd786f5d3ee547cfc403e6f2c0af90106f91c4d4cf3954295f2e5b11e12949ca3069
diff --git a/games-util/xpadneo/files/xpadneo-0.9.6-kernel-6.12.patch b/games-util/xpadneo/files/xpadneo-0.9.6-kernel-6.12.patch
deleted file mode 100644
index 9e5115345111..000000000000
--- a/games-util/xpadneo/files/xpadneo-0.9.6-kernel-6.12.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-https://bugs.gentoo.org/943776
-https://github.com/atar-axis/xpadneo/issues/498
-https://github.com/atar-axis/xpadneo/commit/4bfe0a1c35
-(+ include required linux/version.h from 242e9b46bb)
---- a/hid-xpadneo/src/hid-xpadneo.c
-+++ b/hid-xpadneo/src/hid-xpadneo.c
-@@ -713,5 +713,9 @@
- }
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(6,12,0)
- static u8 *xpadneo_report_fixup(struct hid_device *hdev, u8 *rdesc, unsigned int *rsize)
-+#else
-+static const u8 *xpadneo_report_fixup(struct hid_device *hdev, u8 *rdesc, unsigned int *rsize)
-+#endif
- {
- struct xpadneo_devdata *xdata = hid_get_drvdata(hdev);
---- a/hid-xpadneo/src/xpadneo.h
-+++ b/hid-xpadneo/src/xpadneo.h
-@@ -13,4 +13,5 @@
-
- #include <linux/hid.h>
-+#include <linux/version.h>
-
- #include "hid-ids.h"
diff --git a/games-util/xpadneo/xpadneo-0.9.6.ebuild b/games-util/xpadneo/xpadneo-0.9.6.ebuild
deleted file mode 100644
index 02e62e777f88..000000000000
--- a/games-util/xpadneo/xpadneo-0.9.6.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit linux-mod-r1 udev
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/atar-axis/xpadneo.git"
- EGIT_MIN_CLONE_TYPE="single"
-else
- SRC_URI="https://github.com/atar-axis/xpadneo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~x86"
-fi
-
-DESCRIPTION="Advanced Linux Driver for Xbox One Wireless Controller"
-HOMEPAGE="https://atar-axis.github.io/xpadneo/"
-
-LICENSE="GPL-3"
-SLOT="0"
-
-CONFIG_CHECK="INPUT_FF_MEMLESS"
-
-PATCHES=(
- "${FILESDIR}"/${P}-kernel-6.12.patch
-)
-
-src_compile() {
- local modlist=( hid-${PN}=kernel/drivers/hid:hid-${PN}:hid-${PN}/src )
- local modargs=( KERNEL_SOURCE_DIR="${KV_OUT_DIR}" )
-
- linux-mod-r1_src_compile
-}
-
-src_install() {
- local DOCS=( docs/{[^i]*.md,descriptors,reports} NEWS.md )
- linux-mod-r1_src_install
-
- insinto /etc/modprobe.d
- doins hid-${PN}/etc-modprobe.d/${PN}.conf
-
- udev_dorules hid-${PN}/etc-udev-rules.d/60-${PN}.rules
-}
-
-pkg_postinst() {
- linux-mod-r1_pkg_postinst
- udev_reload
-
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- elog "To pair the gamepad and view module options, see documentation in:"
- elog " ${EROOT}/usr/share/doc/${PF}/"
- fi
-}
-
-pkg_postrm() {
- udev_reload
-}