summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-sports/xmoto
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-sports/xmoto')
-rw-r--r--games-sports/xmoto/Manifest2
-rw-r--r--games-sports/xmoto/files/xmoto-0.5.11-utf8.patch15
-rw-r--r--games-sports/xmoto/metadata.xml8
-rw-r--r--games-sports/xmoto/xmoto-0.5.11.ebuild92
4 files changed, 117 insertions, 0 deletions
diff --git a/games-sports/xmoto/Manifest b/games-sports/xmoto/Manifest
new file mode 100644
index 000000000000..85160782182a
--- /dev/null
+++ b/games-sports/xmoto/Manifest
@@ -0,0 +1,2 @@
+DIST inksmoto-0.7.0.tar.gz 2628941 SHA256 60bd1369d4c347e127886a5813af13daf39b56ce818c9f8b2fc7d4bba0af7e11 SHA512 af0ae49ea160a2274f6835abd82ccaa00dc9ff81875b7d4ea29789388c131b519cb77e6da42efeaf51d52b97090c67320af38145204a1d5418781c99cb23a704 WHIRLPOOL e7137f1f23815cdef1061896b8dd687af38a79be341827dcaa437c39de95a98d94b4173d973899a8422c3e77088da11869957996f21c2822d8cfddf15b6a7ea6
+DIST xmoto-0.5.11-src.tar.gz 40785573 SHA256 a584a6f9292b184686b72c78f16de4b82d5c5b72ad89e41912ff50d03eca26b2 SHA512 7046745e8f7a045fa2ce1deb3fd75b73b233dc1092f5ecd6dd4e42938f70269a93a3a623a39a1f0520c90643a42dc1ce93c43ad07bf225ff6c50741cc02511f6 WHIRLPOOL 9301a6456dea420cc92706022b9003446363d90591f6c90977a1e85195419f42d168456db61077d4e757976ee7ccbb183e6337fda4a683334cea796aa65a7c3b
diff --git a/games-sports/xmoto/files/xmoto-0.5.11-utf8.patch b/games-sports/xmoto/files/xmoto-0.5.11-utf8.patch
new file mode 100644
index 000000000000..5a9c5a499f93
--- /dev/null
+++ b/games-sports/xmoto/files/xmoto-0.5.11-utf8.patch
@@ -0,0 +1,15 @@
+http://todo.xmoto.tuxfamily.org/index.php?do=details&task_id=778
+
+--- src/helpers/utf8.h.orig
++++ src/helpers/utf8.h
+@@ -18,8 +18,8 @@
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ =============================================================================*/
+
+-#ifndef __UTF8_H__
+-#define __UTF8_H__
++#ifndef __XMOTO_UTF8_H__
++#define __XMOTO_UTF8_H__
+
+ #include <vector>
+ #include <string>
diff --git a/games-sports/xmoto/metadata.xml b/games-sports/xmoto/metadata.xml
new file mode 100644
index 000000000000..c502882366e5
--- /dev/null
+++ b/games-sports/xmoto/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name="editor">Depend on inkscape, scripts to convert svg to level (svg2lvl)</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-sports/xmoto/xmoto-0.5.11.ebuild b/games-sports/xmoto/xmoto-0.5.11.ebuild
new file mode 100644
index 000000000000..20aba82da881
--- /dev/null
+++ b/games-sports/xmoto/xmoto-0.5.11.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic games
+
+LVL_PV="0.7.0" #they unfortunately don't release both at the same time, why ~ as separator :(
+LVL="inksmoto-${LVL_PV}"
+DESCRIPTION="A challenging 2D motocross platform game"
+HOMEPAGE="http://xmoto.tuxfamily.org"
+SRC_URI="http://download.tuxfamily.org/xmoto/xmoto/${PV}/${P}-src.tar.gz
+ editor? ( http://download.tuxfamily.org/xmoto/svg2lvl/${LVL_PV}/${LVL}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="editor nls"
+
+RDEPEND="
+ dev-libs/libxdg-basedir
+ dev-db/sqlite:3
+ dev-games/ode
+ dev-lang/lua[deprecated]
+ virtual/jpeg
+ media-libs/libpng
+ dev-libs/libxml2
+ media-libs/libsdl[joystick,opengl]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ media-libs/sdl-net
+ net-misc/curl
+ app-arch/bzip2
+ virtual/opengl
+ virtual/glu
+ media-fonts/dejavu
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ editor? ( media-gfx/inkscape )"
+
+src_prepare() {
+ use editor && rm -vf "${WORKDIR}"/extensions/{bezmisc,inkex}.py
+ sed -i \
+ -e '/^gettextsrcdir/s:=.*:= @localedir@/gettext/po:' \
+ po/Makefile.in.in || die
+
+ epatch "${FILESDIR}"/${P}-utf8.patch
+}
+
+src_configure() {
+ # bug #289792
+ filter-flags -DdDOUBLE
+ has_version 'dev-games/ode[double-precision]' && append-flags -DdDOUBLE
+
+ egamesconf \
+ --disable-dependency-tracking \
+ --enable-threads=posix \
+ $(use_enable nls) \
+ --localedir=/usr/share/locale \
+ --with-localesdir=/usr/share/locale \
+ --with-renderer-sdlGfx=0 \
+ --with-renderer-openGl=1
+}
+
+src_install() {
+ default
+
+ rm -f "${D}${GAMES_DATADIR}/xmoto"/Textures/Fonts/DejaVu*.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}/xmoto"/Textures/Fonts/DejaVuSans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${GAMES_DATADIR}/xmoto"/Textures/Fonts/DejaVuSansMono.ttf
+ doicon extra/xmoto.xpm
+ make_desktop_entry xmoto Xmoto
+
+ prepgamesdirs
+
+ if use editor; then
+ insinto /usr/share/inkscape/
+ doins -r "${WORKDIR}"/extensions/
+ fi
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if use editor; then
+ elog "If you want to know how to create Xmoto levels"
+ elog "have a look at this Tutorial:"
+ elog " http://wiki.xmoto.tuxfamily.org/index.php?title=Inksmoto-${LVL_PV}"
+ elog "You can share your levels on the Xmoto homepage."
+ fi
+}