summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/egoboo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/egoboo')
-rw-r--r--games-rpg/egoboo/Manifest1
-rw-r--r--games-rpg/egoboo/egoboo-2.8.1.ebuild56
-rw-r--r--games-rpg/egoboo/files/egoboo-2.8.1-gentoo.patch56
-rw-r--r--games-rpg/egoboo/metadata.xml8
4 files changed, 121 insertions, 0 deletions
diff --git a/games-rpg/egoboo/Manifest b/games-rpg/egoboo/Manifest
new file mode 100644
index 000000000000..8a9fdae00bab
--- /dev/null
+++ b/games-rpg/egoboo/Manifest
@@ -0,0 +1 @@
+DIST egoboo-2.8.1.tar.gz 150029960 SHA256 a2694187d28a7aadf4ca3b9b7a6c6dcd3bb03ec8f145435c744bb77afb5f4c26 SHA512 5793a63ba90f461ae99bcb81bf4ddf287b203bc2d401e1f697f1f4f93e1d681954e09b23938eb1a36e7dd535e2d12b8882efd77572cc63392cad5f9462ac3054 WHIRLPOOL a4aa29244a43c974f7109ba4a3be40d2438a01c05ac032c4f74e01c2ca407ab3b6033f5133164e853bc50c8b0c59320ac076d21c93ea26ca7089fe8e603a4f6c
diff --git a/games-rpg/egoboo/egoboo-2.8.1.ebuild b/games-rpg/egoboo/egoboo-2.8.1.ebuild
new file mode 100644
index 000000000000..7bdee75374f0
--- /dev/null
+++ b/games-rpg/egoboo/egoboo-2.8.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A 3d dungeon crawling adventure in the spirit of NetHack"
+HOMEPAGE="http://egoboo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[joystick,video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ net-libs/enet:0
+ dev-games/physfs"
+
+src_prepare() {
+ edos2unix src/game/platform/file_linux.c \
+ src/game/network.c \
+ src/game/Makefile
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@GENTOO_CONFDIR@:${GAMES_SYSCONFDIR}/${PN}:" \
+ src/game/platform/file_linux.c || die "sed failed"
+ rm -rf src/enet || die "failed removing enet"
+}
+
+src_compile() {
+ emake -C src/game PROJ_NAME=egoboo-2.x
+}
+
+src_install() {
+ dodoc BUGS.txt Changelog.txt doc/*.txt doc/*.pdf
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r basicdat modules
+ insinto "${GAMES_SYSCONFDIR}/${PN}"
+ doins -r controls.txt setup.txt
+
+ newgamesbin src/game/egoboo-2.x ${PN}
+
+ newicon basicdat/icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Egoboo /usr/share/pixmaps/${PN}.bmp
+
+ prepgamesdirs
+}
diff --git a/games-rpg/egoboo/files/egoboo-2.8.1-gentoo.patch b/games-rpg/egoboo/files/egoboo-2.8.1-gentoo.patch
new file mode 100644
index 000000000000..36cb33b55c54
--- /dev/null
+++ b/games-rpg/egoboo/files/egoboo-2.8.1-gentoo.patch
@@ -0,0 +1,56 @@
+--- src/game/platform/file_linux.c.old 2012-04-29 21:45:29.627419281 +0200
++++ src/game/platform/file_linux.c 2012-04-29 21:45:29.628419211 +0200
+@@ -79,9 +79,9 @@
+ strncpy( linux_dataPath, PREFIX "/share/games/egoboo-2.x", SDL_arraysize( linux_dataPath ) );
+ #else
+ // these are read-only directories
+- strncpy( linux_configPath, "/etc/egoboo-2.x/", SDL_arraysize( linux_configPath ) );
++ strncpy( linux_configPath, "@GENTOO_CONFDIR@", SDL_arraysize( linux_configPath ) );
+ strncpy( linux_binaryPath, "/games/", SDL_arraysize( linux_binaryPath ) );
+- strncpy( linux_dataPath, "/share/games/egoboo-2.x/", SDL_arraysize( linux_dataPath ) );
++ strncpy( linux_dataPath, "@GENTOO_DATADIR@", SDL_arraysize( linux_dataPath ) );
+ #endif
+
+ // the log file cannot be started until there is a user data path to dump the file into
+--- src/game/network.c.old 2012-04-29 20:14:31.482179973 +0200
++++ src/game/network.c 2012-04-29 20:14:52.077730184 +0200
+@@ -37,7 +37,7 @@
+ #include "egoboo_setup.h"
+ #include "egoboo.h"
+
+-#include "enet/enet.h"
++#include <enet/enet.h>
+ #include "file_common.h"
+
+ #include <stdarg.h>
+--- src/game/Makefile.old 2012-04-29 20:17:09.303070070 +0200
++++ src/game/Makefile 2012-04-29 20:18:21.047023847 +0200
+@@ -33,8 +33,7 @@
+ # the compiler options
+
+-CC := gcc
+-INC := -I. -I.. -I../enet/include ${SDLCONF_I} -I./extensions -I./file_formats -I./platform
+-LDFLAGS := ${SDLCONF_L} -L../enet/lib -lSDL_ttf -lSDL_mixer -lGL -lGLU -lSDL_image -lphysfs -lenet
++INC := -I. -I.. ${SDLCONF_I} -I./extensions -I./file_formats -I./platform
++LDLIBS := ${SDLCONF_L} -lSDL_ttf -lSDL_mixer -lGL -lGLU -lSDL_image -lphysfs -lenet -lm
+
+ # use different options if the environmental variable PREFIX is defined
+ ifdef ($(PREFIX),"")
+@@ -43,7 +43,7 @@
+ OPT := -Os -Wall -DPREFIX=\"${PREFIX}\" -D_NIX_PREFIX
+ endif
+
+-CFLAGS := ${OPT} ${INC}
++CFLAGS += ${INC} -DENET11
+
+ #------------------------------------
+ # definitions of the target projects
+@@ -52,7 +52,7 @@
+ all: ${EGO_BIN}
+
+ ${EGO_BIN}: ${EGO_OBJ}
+- ${CC} -o $@ $^ ${LDFLAGS} ${CFLAGS}
++ ${CC} -o $@ $^ ${LDFLAGS} ${CFLAGS} ${LDLIBS}
+
+ clean:
+ rm -f ${ENET_OBJ} ${EGO_OBJ} ${EGO_BIN}
diff --git a/games-rpg/egoboo/metadata.xml b/games-rpg/egoboo/metadata.xml
new file mode 100644
index 000000000000..1b59e3704af2
--- /dev/null
+++ b/games-rpg/egoboo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">egoboo</remote-id>
+ </upstream>
+</pkgmetadata>