summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-19 22:51:22 +0000
committerSam James <sam@gentoo.org>2022-03-19 23:33:23 +0000
commit493d545eb75a4cb1672a2377211b4dbb6fe3488b (patch)
tree918397471b55f2a48c32fbecd94857af3d2566b2 /games-puzzle
parentgames-puzzle/braincurses: [QA] fix tc-get* quoting (diff)
downloadgentoo-493d545eb75a4cb1672a2377211b4dbb6fe3488b.tar.gz
gentoo-493d545eb75a4cb1672a2377211b4dbb6fe3488b.tar.bz2
gentoo-493d545eb75a4cb1672a2377211b4dbb6fe3488b.zip
games-puzzle/construo: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/construo/construo-0.2.3.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/games-puzzle/construo/construo-0.2.3.ebuild b/games-puzzle/construo/construo-0.2.3.ebuild
index 89c4de46b053..740a6c5787db 100644
--- a/games-puzzle/construo/construo-0.2.3.ebuild
+++ b/games-puzzle/construo/construo-0.2.3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit autotools desktop toolchain-funcs
DESCRIPTION="2d construction toy with objects that react on physical forces"
@@ -12,12 +13,10 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="
- media-libs/freeglut
+RDEPEND="media-libs/freeglut
virtual/glu
virtual/opengl
- x11-libs/libXxf86vm
-"
+ x11-libs/libXxf86vm"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
@@ -32,11 +31,12 @@ src_prepare() {
}
src_compile() {
- emake AR=$(tc-getAR)
+ emake AR="$(tc-getAR)"
}
src_install() {
default
- make_desktop_entry "${PN}.glut" "${PN}.glut"
- make_desktop_entry "${PN}.x11" "${PN}.x11"
+
+ make_desktop_entry ${PN}.glut ${PN}.glut
+ make_desktop_entry ${PN}.x11 ${PN}.x11
}