summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-09-28 16:53:48 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-09-28 18:50:03 -0400
commitcecff2663a5b57278bd8e6e5f7a60ce86292614f (patch)
tree9d7c50da96366748d152b4e8e8f6952dcef96aa7 /games-puzzle/flobopuyo/flobopuyo-0.20-r3.ebuild
parentapp-xemacs/xslide: Remove redundant version (diff)
downloadgentoo-cecff2663a5b57278bd8e6e5f7a60ce86292614f.tar.gz
gentoo-cecff2663a5b57278bd8e6e5f7a60ce86292614f.tar.bz2
gentoo-cecff2663a5b57278bd8e6e5f7a60ce86292614f.zip
games-puzzle/flobopuyo: EAPI6->8, fix runtime with optimizations
Works with -O0, but broke at -O2 likely some gcc versions ago. Also: * cleanup patches, and while there have Makefile use pkg-config, echo commands, and respect CPPFLAGS * add missing [joystick], bison, and flex deps * removed dead HOMEPAGE, no replacement found Closes: https://bugs.gentoo.org/815262 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle/flobopuyo/flobopuyo-0.20-r3.ebuild')
-rw-r--r--games-puzzle/flobopuyo/flobopuyo-0.20-r3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/games-puzzle/flobopuyo/flobopuyo-0.20-r3.ebuild b/games-puzzle/flobopuyo/flobopuyo-0.20-r3.ebuild
new file mode 100644
index 000000000000..295962f0e661
--- /dev/null
+++ b/games-puzzle/flobopuyo/flobopuyo-0.20-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Clone of the famous PuyoPuyo game"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="
+ mirror://gentoo/${P}.tgz
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="opengl"
+
+RDEPEND="
+ media-libs/libsdl[joystick,sound,video]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[mod]
+ opengl? ( media-libs/libglvnd )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc41.patch
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-segfault.patch
+)
+
+src_prepare() {
+ default
+
+ rm data/sfx/._bi || die
+}
+
+src_compile() {
+ tc-export CC CXX PKG_CONFIG
+
+ emake PREFIX="${EPREFIX}"/usr ENABLE_OPENGL=$(usex opengl true false)
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}"/usr DESTDIR="${D}" install
+
+ dodoc Changelog TODO
+ doman man/flobopuyo.6
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry flobopuyo FloboPuyo
+}