summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/brainparty
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/brainparty')
-rw-r--r--games-puzzle/brainparty/Manifest1
-rw-r--r--games-puzzle/brainparty/brainparty-0.61.ebuild49
-rw-r--r--games-puzzle/brainparty/files/brainparty-0.61-gcc49.patch20
-rw-r--r--games-puzzle/brainparty/files/brainparty-0.61-savegame.patch27
-rw-r--r--games-puzzle/brainparty/metadata.xml8
5 files changed, 105 insertions, 0 deletions
diff --git a/games-puzzle/brainparty/Manifest b/games-puzzle/brainparty/Manifest
new file mode 100644
index 000000000000..c8e952484359
--- /dev/null
+++ b/games-puzzle/brainparty/Manifest
@@ -0,0 +1 @@
+DIST brainparty0.61.tar.gz 40676905 SHA256 6930b563b45f935451b28fa3ed5d33619e766885f82656a3eb48c6d30671a625 SHA512 bc8578a551ce4b7f40e212d9ab9910b2435b88d8b7b7e90a1c088e37d5f26b5c6126fcb9ffee7e39981eff34c13144c8f3204e020532b5abf1c4815cc8074eb9 WHIRLPOOL b8c9065af334a7f404faab934922841adf860fbc36734ae44ba582e7c30f218236c2f266347f1de596e0036f5139e16c5e4702899b83025e5f60fcc1fc36d258
diff --git a/games-puzzle/brainparty/brainparty-0.61.ebuild b/games-puzzle/brainparty/brainparty-0.61.ebuild
new file mode 100644
index 000000000000..3b5c5abb1f65
--- /dev/null
+++ b/games-puzzle/brainparty/brainparty-0.61.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A puzzle-solving, brain-stretching game for all ages"
+HOMEPAGE="http://www.tuxradar.com/brainparty"
+SRC_URI="http://launchpad.net/brainparty/trunk/${PV}/+download/${PN}${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,opengl,video]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ media-libs/sdl-image[png]
+ media-libs/sdl-gfx"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e 's/$(LIBS) $(OSXCOMPAT) $(OBJFILES)/$(OSXCOMPAT) $(OBJFILES) $(LIBS)/' \
+ -e 's/CXXFLAGS = .*/CXXFLAGS+=-c/' \
+ -e '/^CXX =/d' \
+ -e '/-o brainparty/s/INCLUDES) /&$(LDFLAGS) /' \
+ Makefile || die
+ sed -i \
+ "/^int main(/ a\\\\tchdir(\"${GAMES_DATADIR}/${PN}\");\n" \
+ main.cpp || die
+ epatch \
+ "${FILESDIR}"/${P}-savegame.patch \
+ "${FILESDIR}"/${P}-gcc49.patch
+
+}
+
+src_install() {
+ dogamesbin brainparty
+ insinto "${GAMES_DATADIR}/${PN}/Content"
+ doins Content/*
+ newicon Content/icon.bmp ${PN}.bmp
+ make_desktop_entry brainparty "Brain Party" /usr/share/pixmaps/${PN}.bmp
+ prepgamesdirs
+}
diff --git a/games-puzzle/brainparty/files/brainparty-0.61-gcc49.patch b/games-puzzle/brainparty/files/brainparty-0.61-gcc49.patch
new file mode 100644
index 000000000000..7147cd460be6
--- /dev/null
+++ b/games-puzzle/brainparty/files/brainparty-0.61-gcc49.patch
@@ -0,0 +1,20 @@
+--- a/BPList.h
++++ a/BPList.h
+@@ -138,7 +138,7 @@
+ ~BPPList();
+ void Add(T item);
+ bool Contains(T item);
+- void Clear(bool safe_delete);
++ void Clear(bool safe_delete = true);
+ int IndexOf(T item);
+ void Insert(int pos, T item);
+ void Remove(T item);
+@@ -171,7 +171,7 @@
+ }
+
+ template <class T>
+-void BPPList<T>::Clear(bool safe_delete = true) {
++void BPPList<T>::Clear(bool safe_delete) {
+ if (safe_delete) {
+ for (int i = data.size() - 1; i >= 0; --i) {
+ T item = data[i];
diff --git a/games-puzzle/brainparty/files/brainparty-0.61-savegame.patch b/games-puzzle/brainparty/files/brainparty-0.61-savegame.patch
new file mode 100644
index 000000000000..08526d345100
--- /dev/null
+++ b/games-puzzle/brainparty/files/brainparty-0.61-savegame.patch
@@ -0,0 +1,27 @@
+--- a/BPGame.cpp
++++ b/BPGame.cpp
+@@ -1294,8 +1294,10 @@ void BPGame::LoadSettings() {
+ Secret1 = Secret2 = Secret3 = Secret4 = false;
+ NumUnlockedGames = 0;
+
++ string file = string("/.brainparty");
++ file.insert(0, getenv("HOME"));
+ ifstream ifs;
+- ifs.open(".brainparty");
++ ifs.open(file.c_str());
+
+ FirstRun = false;
+
+@@ -1425,8 +1428,11 @@ void BPGame::LoadSettings() {
+ }
+
+ void BPGame::SaveSettings() {
++ string file = string("/.brainparty");
++ file.insert(0, getenv("HOME"));
++
+ ofstream savefile;
+- savefile.open(".brainparty");
++ savefile.open(file.c_str());
+ savefile << EnableSound << endl;
+ savefile << EnableMusic << endl;
+ savefile << endl;
diff --git a/games-puzzle/brainparty/metadata.xml b/games-puzzle/brainparty/metadata.xml
new file mode 100644
index 000000000000..edd52d2870d2
--- /dev/null
+++ b/games-puzzle/brainparty/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="launchpad">brainparty</remote-id>
+ </upstream>
+</pkgmetadata>