summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-04-17 19:27:21 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-04-17 19:27:21 -0400
commit827062b5582fbd93848545197aecce6efdc68e22 (patch)
treea1ec8cf722d3620a74ca4517f085d5cf653c8016 /games-arcade/performous/files
parentapp-portage/pfl: Fix metadata.xml file. (diff)
downloadgentoo-827062b5582fbd93848545197aecce6efdc68e22.tar.gz
gentoo-827062b5582fbd93848545197aecce6efdc68e22.tar.bz2
gentoo-827062b5582fbd93848545197aecce6efdc68e22.zip
games-arcade/performous: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-arcade/performous/files')
-rw-r--r--games-arcade/performous/files/performous-1.1-gentoo.patch12
-rw-r--r--games-arcade/performous/files/performous-1.1-linguas.patch18
2 files changed, 30 insertions, 0 deletions
diff --git a/games-arcade/performous/files/performous-1.1-gentoo.patch b/games-arcade/performous/files/performous-1.1-gentoo.patch
new file mode 100644
index 000000000000..a73663a88c41
--- /dev/null
+++ b/games-arcade/performous/files/performous-1.1-gentoo.patch
@@ -0,0 +1,12 @@
+diff -ru performous-1.0.orig/game/CMakeLists.txt performous-1.0/game/CMakeLists.txt
+--- performous-1.0.orig/game/CMakeLists.txt 2014-10-28 19:11:45.000000000 -0400
++++ performous-1.0/game/CMakeLists.txt 2015-03-31 03:01:30.806061643 -0400
+@@ -141,7 +141,7 @@
+ set(BIN_INSTALL .) # Straight to Program Files/Performous with no bin subfolder.
+ set(SUBSYSTEM_WIN32 WIN32)
+ else()
+- set(BIN_INSTALL bin)
++ set(BIN_INSTALL @GENTOO_BINDIR@)
+ endif()
+
+ # Build main executable
diff --git a/games-arcade/performous/files/performous-1.1-linguas.patch b/games-arcade/performous/files/performous-1.1-linguas.patch
new file mode 100644
index 000000000000..f8f1349ea3b9
--- /dev/null
+++ b/games-arcade/performous/files/performous-1.1-linguas.patch
@@ -0,0 +1,18 @@
+diff -ru performous-1.0.orig/lang/CMakeLists.txt performous-1.0/lang/CMakeLists.txt
+--- performous-1.0.orig/lang/CMakeLists.txt 2014-10-28 19:11:45.000000000 -0400
++++ performous-1.0/lang/CMakeLists.txt 2015-02-22 04:25:40.502252942 -0500
+@@ -9,5 +9,13 @@
+ file(MAKE_DIRECTORY "${mobuild}")
+ add_custom_command(OUTPUT "${mofile}" COMMAND "${Msgfmt_BIN}" -v "${pofile}" -o "${mofile}" MAIN_DEPENDENCY "${pofile}" COMMENT "Building ${language} locale" VERBATIM)
+ add_custom_target("locale_${language}" ALL DEPENDS "${mofile}") # Make sure the mofiles are always built
+- install(FILES "${mofile}" DESTINATION "${LOCALE_DIR}/${language}/LC_MESSAGES")
+ endforeach(language)
++foreach(language $ENV{LINGUAS})
++ set(pofile ${CMAKE_CURRENT_SOURCE_DIR}/${language}.po)
++ if (EXISTS ${pofile})
++ set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo)
++ install(FILES ${mofile} DESTINATION
++{LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo)
++ endif()
++endforeach(language)
++