summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-01-07 14:21:27 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-01-07 14:22:42 +0300
commit6423e37b129b86c3cb4fc39d3e97bb3f6c5bf49a (patch)
treeb2cc9863d482b5d2104d5b05ccff9b5ef2edf978 /dev-vcs
parentnet-irc/rbot: Test LINGUAS rather than linguas_* USE flags. (diff)
downloadgentoo-6423e37b129b86c3cb4fc39d3e97bb3f6c5bf49a.tar.gz
gentoo-6423e37b129b86c3cb4fc39d3e97bb3f6c5bf49a.tar.bz2
gentoo-6423e37b129b86c3cb4fc39d3e97bb3f6c5bf49a.zip
dev-vcs/qct: remove last rited package
Closes: https://bugs.gentoo.org/640138
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/qct/Manifest1
-rw-r--r--dev-vcs/qct/files/qct.rc3
-rw-r--r--dev-vcs/qct/metadata.xml22
-rw-r--r--dev-vcs/qct/qct-1.7-r2.ebuild71
4 files changed, 0 insertions, 97 deletions
diff --git a/dev-vcs/qct/Manifest b/dev-vcs/qct/Manifest
deleted file mode 100644
index 7ca3c42b4e35..000000000000
--- a/dev-vcs/qct/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST qct-1.7.tar.gz 56658 BLAKE2B 68f7c4632b4fb04154800d5677b70eb722b6f635c9f742d114fec0f3a2c8673a7a7f24fbf15b833264af7c664a321d76b2c1ec551f2502f84c1a2707c0920009 SHA512 85f8b6bcd5c4081ba17da1bc7e17d0036ec10d9133ed5383adbca16f81b8550d6f137e34636c20f3d03b7cedca75467daa057022374866b4e2ab18aaf7d4b6d2
diff --git a/dev-vcs/qct/files/qct.rc b/dev-vcs/qct/files/qct.rc
deleted file mode 100644
index 3ab69befa3c5..000000000000
--- a/dev-vcs/qct/files/qct.rc
+++ /dev/null
@@ -1,3 +0,0 @@
-[extensions]
-hgext.qct=
-
diff --git a/dev-vcs/qct/metadata.xml b/dev-vcs/qct/metadata.xml
deleted file mode 100644
index d821bbf0b013..000000000000
--- a/dev-vcs/qct/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>qt@gentoo.org</email>
- <name>Gentoo Qt Project</name>
- </maintainer>
- <use>
- <flag name="bazaar">
- Support for <pkg>dev-vcs/bzr</pkg>
- </flag>
- <flag name="mercurial">
- Support for <pkg>dev-vcs/mercurial</pkg>
- </flag>
- <flag name="monotone">
- Support for <pkg>dev-vcs/monotone</pkg>
- </flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">qct</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-vcs/qct/qct-1.7-r2.ebuild b/dev-vcs/qct/qct-1.7-r2.ebuild
deleted file mode 100644
index 0093c1bb1ff4..000000000000
--- a/dev-vcs/qct/qct-1.7-r2.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1
-
-DESCRIPTION="PyQt based commit tool for many VCSs"
-HOMEPAGE="http://qct.sourceforge.net/"
-SRC_URI="http://qct.sourceforge.net/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bazaar cvs mercurial monotone subversion"
-
-DEPEND="
- app-text/asciidoc
- app-text/xmlto
- dev-python/PyQt4[${PYTHON_USEDEP}]
- bazaar? ( dev-vcs/bzr[${PYTHON_USEDEP}] )
- cvs? ( dev-vcs/cvs )
- mercurial? ( dev-vcs/mercurial[${PYTHON_USEDEP}] )
- monotone? ( dev-vcs/monotone )
- subversion? ( dev-vcs/subversion[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-python_prepare_all() {
- # support for git requires cogito which isn't in portage
- rm qctlib/vcs/{p4,git,cg}.py || die
-
- declare -A delfiles=([bazaar]=bzr [cvs]=cvs [mercurial]=hg [monotone]=mtn [subversion]=svn)
- local i
- for i in "${!delfiles[@]}"; do
- if ! use $i; then
- rm qctlib/vcs/${delfiles[$i]}.py || die
- fi
- done
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # manpage and html docs are built using asciidoc
- emake -C doc man html
- HTML_DOCS=( doc/qct.1.html )
-}
-
-python_install_all() {
- doman doc/qct.1
-
- if use bazaar; then
- python_moduleinto bzrlib/plugins
- python_domodule plugins/qctBzrPlugin.py
- fi
-
- if use mercurial; then
- python_moduleinto hgext
- python_domodule hgext/qct.py
-
- insinto /etc/mercurial/hgrc.d
- doins "${FILESDIR}/qct.rc"
- fi
-
- distutils-r1_python_install_all
-}