summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-04-15 13:13:38 +0100
committerMarek Szuba <marecki@gentoo.org>2024-04-15 13:20:24 +0100
commitf947462c2ef00ee58d1ade747d5b8bca1f104a3b (patch)
tree912b0e550080855af43bd094c31733a03b8a9545 /dev-vcs/git-machete
parentdev-python/pdm-backend: Bump to 2.2.0 (diff)
downloadgentoo-f947462c2ef00ee58d1ade747d5b8bca1f104a3b.tar.gz
gentoo-f947462c2ef00ee58d1ade747d5b8bca1f104a3b.tar.bz2
gentoo-f947462c2ef00ee58d1ade747d5b8bca1f104a3b.zip
dev-vcs/git-machete: add 3.25.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs/git-machete')
-rw-r--r--dev-vcs/git-machete/Manifest1
-rw-r--r--dev-vcs/git-machete/git-machete-3.25.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-vcs/git-machete/Manifest b/dev-vcs/git-machete/Manifest
index 5ed74f4c0339..48e972b2c48c 100644
--- a/dev-vcs/git-machete/Manifest
+++ b/dev-vcs/git-machete/Manifest
@@ -1,2 +1,3 @@
DIST git-machete-3.20.0.gh.tar.gz 1645348 BLAKE2B d07a7a78e835eb1afbed40d4133ba9ed914492cce03fbcd5c63bdd4260e65b6300e77d1f33175c7471667f044960b2948278db27b2d29731e7afe86564207311 SHA512 ba2a7e6741ad6cf47577301dd810fcd2bf7b2436fedf4b5fd566faad62fae54861d21b14ffa9395297e28e4176a9710b13e22dbb917bc7a8cc7f9f286c9f8afc
DIST git-machete-3.24.2.gh.tar.gz 1866234 BLAKE2B c8b5fa711af3f4cdbb9449c4bc34f3e0b629f22c33a6b1f2e84954ece20545e68605dedc2203ddfc5334132fcdf4b0f2fc20739e65e67425bcb483e480ef3f81 SHA512 37cdd1f76946cb14bdcd819fe270e521ef3fac9802b44c6fb3f172b5508003562e2f6ba541ca6eaac37516129d2a4be67d972be29cef1f09aea48f96b00068ab
+DIST git-machete-3.25.0.gh.tar.gz 1892248 BLAKE2B b666c82ef84819206e6e53b76e6739e1c267c0e2f21dea2c112949a7195c5e6a914c248cee16a10a1a1ebddb56ab01da247832941f680a45bbbedd2871182c59 SHA512 5ccff4fc65287a202f2166f6301bb8618656a76039620c6b7f7abfc5bfa808e6538322bb335d6c816eb25d7ce7092cdf9dfc21e124feb1cd43f1e8abe911eebc
diff --git a/dev-vcs/git-machete/git-machete-3.25.0.ebuild b/dev-vcs/git-machete/git-machete-3.25.0.ebuild
new file mode 100644
index 000000000000..550b46b65536
--- /dev/null
+++ b/dev-vcs/git-machete/git-machete-3.25.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Probably the sharpest git repo organizer & rebase/merge workflow automation tool"
+HOMEPAGE="https://github.com/VirtusLab/git-machete https://pypi.org/project/git-machete/"
+# No tests in PyPI tarballs
+SRC_URI="https://github.com/VirtusLab/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="dev-vcs/git"
+BDEPEND="test? (
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.2.1[${PYTHON_USEDEP}]
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.24.2_no-strays-in-site-packages.patch
+)
+
+DOCS=( CONTRIBUTING.md README.md )
+
+distutils_enable_tests pytest
+
+# Several of the fish- and zsh-completion tests appear to be broken
+EPYTEST_DESELECT=(
+ tests/completion_e2e/test_completion_e2e.py::TestCompletionEndToEnd::test_completion
+)
+
+src_install() {
+ distutils-r1_src_install
+
+ doman docs/man/${PN}.1
+
+ newbashcomp completion/${PN}.completion.bash ${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completion/${PN}.fish
+
+ insinto /usr/share/zsh/site-functions
+ newins completion/${PN}.completion.zsh _${PN}
+}