summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-06 06:16:21 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-06 06:26:38 +0100
commit9c3fd03cab292aeb7e7d80a4963dd099906deb1f (patch)
treef5eafcbaeeb5a79c7d9ab299dfe23b9c2dff370a /dev-util
parentdev-python/tox: Bump to 4.2.4 (diff)
downloadgentoo-9c3fd03cab292aeb7e7d80a4963dd099906deb1f.tar.gz
gentoo-9c3fd03cab292aeb7e7d80a4963dd099906deb1f.tar.bz2
gentoo-9c3fd03cab292aeb7e7d80a4963dd099906deb1f.zip
dev-util/stripe-mock: Bump to 0.149.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.149.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index 394d2df6a062..618df96d644f 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -3,3 +3,4 @@ DIST stripe-mock-0.145.0.tar.gz 579773 BLAKE2B f2661daf70f2073ce475b53e591d08ddb
DIST stripe-mock-0.146.0.tar.gz 561719 BLAKE2B 30b7fb51de192e94157bdbe7d9c5598749b3bbf8f8f6e17b39bd4396da09ca8ded5fdfcdea1034274fd877a0e2356d5ea9820df05c75fd88a98c4a60e8bf7714 SHA512 d9680d41f20382a1bef5fec6ae5e0970781e169ad77151838b32ce2ffc4d2d024276c44dbc998f2a2a0a20b90e75241b78e6d6dfa282fafb9486990653af6c63
DIST stripe-mock-0.147.0.tar.gz 563420 BLAKE2B c0ec61e12081bed396993db28a690d267004ed078d6ad593e4c5543da7b77b5014cb097ab3cc992cdb704a7037efc72e37d7b3c280cfa403cb5d36e1b56f5e53 SHA512 4f017c5e1a76f9922acecbaf3abebf23df18d2b24321e50cd14761d67b938ddfcf92fe7641fa36a8d9d67a63dab5ce0f6a40050a7a3472da93973aa9efec6ead
DIST stripe-mock-0.148.0.tar.gz 563990 BLAKE2B 98d16fea7e9a99bfdfd9c42dec09e0428abafaf99924254c862a209184240825af2cba925acb8bd40850c0d4f4f4477460c90c6ec70676bf65961e99ed495c68 SHA512 bf7d4d03f9d473b34ffb31a16521685cac9369e261f2d00ec77206a42f73a363d5f2528744ebb316525c236e56568375330499bfd2abdb9a37c6a742bb1fe2b7
+DIST stripe-mock-0.149.0.tar.gz 564059 BLAKE2B 8012431b1c4671ccdbe71950013008bed54b87baf962c370869b184441fbd72c338d078331078db4b0eeaadfb7b82438a22c5b1afb433ba66f5302496d4991b4 SHA512 e3364b09d11be2ef1545fca446d6648ff0ee4e85b4ebdcdea7a864fc85a6fa397a4eacc3ba47c971a32b62d6092eb32f66fca530f5fabab31932fee5a677edb6
diff --git a/dev-util/stripe-mock/stripe-mock-0.149.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.149.0.ebuild
new file mode 100644
index 000000000000..ca0f4e60efa7
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.149.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock/"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}