summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-14 16:53:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-14 16:55:53 +0200
commitdfd1cccca3ad94e4bd0401f740d02bf723a9edb3 (patch)
tree71c688ac9ebe0f96e09e7a76c3cfd784ba18be2c /dev-util
parentgames-board/chessx: Drop old (diff)
downloadgentoo-dfd1cccca3ad94e4bd0401f740d02bf723a9edb3.tar.gz
gentoo-dfd1cccca3ad94e4bd0401f740d02bf723a9edb3.tar.bz2
gentoo-dfd1cccca3ad94e4bd0401f740d02bf723a9edb3.zip
dev-util/kdstatemachineeditor: Fix build with Qt 5.11
Thanks-to: Petross404(Petros S) <petross404@gmail.com> Closes: https://bugs.gentoo.org/656672 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/kdstatemachineeditor/files/kdstatemachineeditor-1.2.3-qt-5.11.patch21
-rw-r--r--dev-util/kdstatemachineeditor/kdstatemachineeditor-1.2.3.ebuild2
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/kdstatemachineeditor/files/kdstatemachineeditor-1.2.3-qt-5.11.patch b/dev-util/kdstatemachineeditor/files/kdstatemachineeditor-1.2.3-qt-5.11.patch
new file mode 100644
index 000000000000..04a9ac9306b6
--- /dev/null
+++ b/dev-util/kdstatemachineeditor/files/kdstatemachineeditor-1.2.3-qt-5.11.patch
@@ -0,0 +1,21 @@
+From 63ca52af50f94b396182638224fe2c50b4cb7043 Mon Sep 17 00:00:00 2001
+From: Allen Winter <allen.winter@kdab.com>
+Date: Thu, 5 Apr 2018 10:07:01 -0400
+Subject: [PATCH] src/core/model/element.h - fix compile on with XCode (include QPointF)
+
+---
+ src/core/model/element.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/core/model/element.h b/src/core/model/element.h
+index ec32cfc..c20ac6f 100644
+--- a/src/core/model/element.h
++++ b/src/core/model/element.h
+@@ -30,6 +30,7 @@
+
+ #include <QObject>
+ #include <QMetaType>
++#include <QPointF>
+
+ QT_BEGIN_NAMESPACE
+ class QPainterPath; \ No newline at end of file
diff --git a/dev-util/kdstatemachineeditor/kdstatemachineeditor-1.2.3.ebuild b/dev-util/kdstatemachineeditor/kdstatemachineeditor-1.2.3.ebuild
index 879b2ad3bded..0ccb11dd407c 100644
--- a/dev-util/kdstatemachineeditor/kdstatemachineeditor-1.2.3.ebuild
+++ b/dev-util/kdstatemachineeditor/kdstatemachineeditor-1.2.3.ebuild
@@ -36,6 +36,8 @@ DEPEND="${RDEPEND}
media-gfx/graphviz
"
+PATCHES=( "${FILESDIR}"/${P}-qt-5.11.patch )
+
src_configure() {
local mycmakeargs=(
-DBUILD_EXAMPLES=OFF