summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-07-28 09:55:55 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-07-28 10:02:34 -0400
commitdf2f0bafac3657579f2be99174448007b0df35d8 (patch)
treed8a7f7f12e34c46b2f152a74ff087957dcf7c5fb /dev-util
parentsys-libs/libnvme: add github upstream metadata (diff)
downloadgentoo-df2f0bafac3657579f2be99174448007b0df35d8.tar.gz
gentoo-df2f0bafac3657579f2be99174448007b0df35d8.tar.bz2
gentoo-df2f0bafac3657579f2be99174448007b0df35d8.zip
dev-util/maturin: sync riscv check in _beta1
Not needed now, but next bump will be based on _beta1's conditions and don't want to forget it. At this point it's tempting to just disable it for all arches except amd64/x86/arm*, but upstream keeps a similar per-arch exclusion list so keeping as-is for now. Also move filter-lto in the right phase since it's defined. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/maturin/maturin-0.13.2_beta1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-util/maturin/maturin-0.13.2_beta1.ebuild b/dev-util/maturin/maturin-0.13.2_beta1.ebuild
index 923cbd019f20..4432c450ae14 100644
--- a/dev-util/maturin/maturin-0.13.2_beta1.ebuild
+++ b/dev-util/maturin/maturin-0.13.2_beta1.ebuild
@@ -387,17 +387,17 @@ src_prepare() {
# TODO: package-agnostic way to handle IUSE=debug with setuptools-rust?
use !debug || sed -i "s/^cargo_args = \[/&'--profile','dev',/" setup.py || die
- filter-lto # undefined references with ring crate
-
# setup.py handles most for non-tests, but ensure disabled rustls on arches
# where ring crate is problematic -- keep in sync below (bug #859577)
- if use mips || use ppc || use ppc64 || use s390 || use sparc; then
+ if use mips || use ppc || use ppc64 || use riscv || use s390 || use sparc; then
sed -i '/^if platform.machine/s/^if/if True or/' setup.py || die
fi
}
src_configure() {
- if use mips || use ppc || use ppc64 || use s390 || use sparc; then
+ filter-lto # undefined references with ring crate
+
+ if use mips || use ppc || use ppc64 || use riscv || use s390 || use sparc; then
local myfeatures=( upload log human-panic )
cargo_src_configure --no-default-features
fi