summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-15 13:35:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-19 21:48:00 +0200
commit5399d78db2f9f64175fe19c4d392a3f3d9cbee94 (patch)
tree0a16ac9bc5d51d004dee380b98f7fb40310da448 /dev-util/sasm
parentdev-libs/libzip: Drop 1.7.1 (diff)
downloadgentoo-5399d78db2f9f64175fe19c4d392a3f3d9cbee94.tar.gz
gentoo-5399d78db2f9f64175fe19c4d392a3f3d9cbee94.tar.bz2
gentoo-5399d78db2f9f64175fe19c4d392a3f3d9cbee94.zip
dev-util/sasm: EAPI-7 bump
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/sasm')
-rw-r--r--dev-util/sasm/sasm-2.2-r1.ebuild12
-rw-r--r--dev-util/sasm/sasm-3.10.1.ebuild20
2 files changed, 13 insertions, 19 deletions
diff --git a/dev-util/sasm/sasm-2.2-r1.ebuild b/dev-util/sasm/sasm-2.2-r1.ebuild
index 7c9c73aab793..6af06e5653bc 100644
--- a/dev-util/sasm/sasm-2.2-r1.ebuild
+++ b/dev-util/sasm/sasm-2.2-r1.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit qmake-utils
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/Dman95/SASM.git"
- SRC_URI=""
inherit git-r3
else
SRC_URI="https://github.com/Dman95/SASM/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/SASM-${PV}"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${P^^}"
fi
DESCRIPTION="Simple crossplatform IDE for NASM assembly language"
@@ -19,8 +19,6 @@ HOMEPAGE="http://dman95.github.io/SASM/"
LICENSE="GPL-3"
SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="
diff --git a/dev-util/sasm/sasm-3.10.1.ebuild b/dev-util/sasm/sasm-3.10.1.ebuild
index 90ca72d53168..7b82aa3b818b 100644
--- a/dev-util/sasm/sasm-3.10.1.ebuild
+++ b/dev-util/sasm/sasm-3.10.1.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit qmake-utils
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/Dman95/SASM.git"
- SRC_URI=""
inherit git-r3
else
SRC_URI="https://github.com/Dman95/SASM/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/SASM-${PV}"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${P^^}"
fi
DESCRIPTION="Simple crossplatform IDE for NASM assembly language"
@@ -19,13 +19,9 @@ HOMEPAGE="http://dman95.github.io/SASM/"
LICENSE="GPL-3"
SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~x86"
IUSE=""
-PATCHES=(
- "${FILESDIR}"/${P}-unbundle-qtsingleapplication.patch
-)
+PATCHES=( "${FILESDIR}"/${P}-unbundle-qtsingleapplication.patch )
DEPEND="
dev-qt/qtcore:5
@@ -42,13 +38,13 @@ REPEND="${DEPEND}
QA_PREBUILT="usr/bin/fasm usr/bin/listing"
src_prepare() {
+ default
+
# To recompress it with gentoo tools
gunzip Linux/share/doc/sasm/changelog.gz || die
sed -e 's@changelog.gz@changelog@g' \
-e '/docfiles.path/s@doc/sasm@doc/'${PF}'@g' \
-i SASM.pro || die
-
- default
}
src_configure() {