summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-22 21:05:35 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-22 21:12:53 +0100
commit2096536625461c902c7fa5032b0be96ed34fa5b3 (patch)
tree2413a75bb84fa498830c6229cd12d16f4d0e5ae5 /dev-util/roctracer
parentRename dev-python/{ConfigArgParse → configargparse} (diff)
downloadgentoo-2096536625461c902c7fa5032b0be96ed34fa5b3.tar.gz
gentoo-2096536625461c902c7fa5032b0be96ed34fa5b3.tar.bz2
gentoo-2096536625461c902c7fa5032b0be96ed34fa5b3.zip
Rename dev-python/{CppHeaderParser → cppheaderparser}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/roctracer')
-rw-r--r--dev-util/roctracer/roctracer-5.1.3-r1.ebuild8
-rw-r--r--dev-util/roctracer/roctracer-5.3.3-r1.ebuild6
-rw-r--r--dev-util/roctracer/roctracer-5.7.1-r1.ebuild4
-rw-r--r--dev-util/roctracer/roctracer-6.1.1-r1.ebuild4
4 files changed, 11 insertions, 11 deletions
diff --git a/dev-util/roctracer/roctracer-5.1.3-r1.ebuild b/dev-util/roctracer/roctracer-5.1.3-r1.ebuild
index 22befb0d4430..923072f3fe67 100644
--- a/dev-util/roctracer/roctracer-5.1.3-r1.ebuild
+++ b/dev-util/roctracer/roctracer-5.1.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit cmake prefix python-any-r1
@@ -23,7 +23,7 @@ RDEPEND="dev-libs/rocr-runtime:${SLOT}
DEPEND="${RDEPEND}"
BDEPEND="
$(python_gen_any_dep '
- dev-python/CppHeaderParser[${PYTHON_USEDEP}]
+ dev-python/cppheaderparser[${PYTHON_USEDEP}]
dev-python/ply[${PYTHON_USEDEP}]
')
"
@@ -38,7 +38,7 @@ PATCHES=(
)
python_check_deps() {
- python_has_version "dev-python/CppHeaderParser[${PYTHON_USEDEP}]" \
+ python_has_version "dev-python/cppheaderparser[${PYTHON_USEDEP}]" \
"dev-python/ply[${PYTHON_USEDEP}]"
}
diff --git a/dev-util/roctracer/roctracer-5.3.3-r1.ebuild b/dev-util/roctracer/roctracer-5.3.3-r1.ebuild
index 54def42e46a6..f5ebd55cf86d 100644
--- a/dev-util/roctracer/roctracer-5.3.3-r1.ebuild
+++ b/dev-util/roctracer/roctracer-5.3.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,7 +25,7 @@ RDEPEND="dev-libs/rocr-runtime
DEPEND="${RDEPEND}"
BDEPEND="
$(python_gen_any_dep '
- dev-python/CppHeaderParser[${PYTHON_USEDEP}]
+ dev-python/cppheaderparser[${PYTHON_USEDEP}]
dev-python/ply[${PYTHON_USEDEP}]
')
"
@@ -35,7 +35,7 @@ PATCHES=( "${FILESDIR}"/roctracer-5.3.3-flat-lib-layout.patch
"${FILESDIR}"/roctracer-5.3.3-Werror.patch )
python_check_deps() {
- python_has_version "dev-python/CppHeaderParser[${PYTHON_USEDEP}]" \
+ python_has_version "dev-python/cppheaderparser[${PYTHON_USEDEP}]" \
"dev-python/ply[${PYTHON_USEDEP}]"
}
diff --git a/dev-util/roctracer/roctracer-5.7.1-r1.ebuild b/dev-util/roctracer/roctracer-5.7.1-r1.ebuild
index e16ea7d01a5a..6c36347c9931 100644
--- a/dev-util/roctracer/roctracer-5.7.1-r1.ebuild
+++ b/dev-util/roctracer/roctracer-5.7.1-r1.ebuild
@@ -25,7 +25,7 @@ RDEPEND="dev-libs/rocr-runtime
DEPEND="${RDEPEND}"
BDEPEND="
$(python_gen_any_dep '
- dev-python/CppHeaderParser[${PYTHON_USEDEP}]
+ dev-python/cppheaderparser[${PYTHON_USEDEP}]
dev-python/ply[${PYTHON_USEDEP}]
')
"
@@ -35,7 +35,7 @@ PATCHES=(
)
python_check_deps() {
- python_has_version "dev-python/CppHeaderParser[${PYTHON_USEDEP}]" \
+ python_has_version "dev-python/cppheaderparser[${PYTHON_USEDEP}]" \
"dev-python/ply[${PYTHON_USEDEP}]"
}
diff --git a/dev-util/roctracer/roctracer-6.1.1-r1.ebuild b/dev-util/roctracer/roctracer-6.1.1-r1.ebuild
index 5ac47938ee4d..685eda9bed74 100644
--- a/dev-util/roctracer/roctracer-6.1.1-r1.ebuild
+++ b/dev-util/roctracer/roctracer-6.1.1-r1.ebuild
@@ -27,7 +27,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
$(python_gen_any_dep '
- dev-python/CppHeaderParser[${PYTHON_USEDEP}]
+ dev-python/cppheaderparser[${PYTHON_USEDEP}]
dev-python/ply[${PYTHON_USEDEP}]
')
"
@@ -37,7 +37,7 @@ PATCHES=(
)
python_check_deps() {
- python_has_version "dev-python/CppHeaderParser[${PYTHON_USEDEP}]" \
+ python_has_version "dev-python/cppheaderparser[${PYTHON_USEDEP}]" \
"dev-python/ply[${PYTHON_USEDEP}]"
}