summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/mutrace
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/mutrace')
-rw-r--r--dev-util/mutrace/Manifest1
-rw-r--r--dev-util/mutrace/files/mutrace-0.2-missing-header.patch10
-rw-r--r--dev-util/mutrace/metadata.xml7
-rw-r--r--dev-util/mutrace/mutrace-0.2.ebuild23
4 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/mutrace/Manifest b/dev-util/mutrace/Manifest
new file mode 100644
index 000000000000..5e3608cc8a9b
--- /dev/null
+++ b/dev-util/mutrace/Manifest
@@ -0,0 +1 @@
+DIST mutrace-0.2.tar.gz 358710 SHA256 38eb62b9c86443361b8222d7088a9dc1e8c1db6b2b01b47c4155234d230dbd23 SHA512 237ef478417a19d5967c80d285dcde68ee8ffce40af4967a3b055347272c66a6bbdfb55ed9bf36633fbaccc7c4fd9c2de09b705ab92b74eefc5e7a7170c0c545 WHIRLPOOL df7320740b0716956c1b2efda81c6a236ae4e54a219ff1f7a07ac456f9c7cc646ea678c01ef4f7b40a439d80cc0ee461dfa88da7400312d50a7f22cba5bbb5e5
diff --git a/dev-util/mutrace/files/mutrace-0.2-missing-header.patch b/dev-util/mutrace/files/mutrace-0.2-missing-header.patch
new file mode 100644
index 000000000000..aa2c32e79d5e
--- /dev/null
+++ b/dev-util/mutrace/files/mutrace-0.2-missing-header.patch
@@ -0,0 +1,10 @@
+--- backtrace-symbols.c 2009-09-30 00:30:08.000000000 +0300
++++ backtrace-symbols.c 2013-10-20 19:54:47.273470222 +0300
+@@ -49,6 +49,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <execinfo.h>
++#include "config.h"
+ #include <bfd.h>
+ #include <libiberty.h>
+ #include <dlfcn.h>
diff --git a/dev-util/mutrace/metadata.xml b/dev-util/mutrace/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/dev-util/mutrace/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/mutrace/mutrace-0.2.ebuild b/dev-util/mutrace/mutrace-0.2.ebuild
new file mode 100644
index 000000000000..4755465bb5c8
--- /dev/null
+++ b/dev-util/mutrace/mutrace-0.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A mutex tracer/profiler"
+HOMEPAGE="http://0pointer.de/blog/projects/mutrace.html"
+SRC_URI="http://0pointer.de/public/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~arm"
+IUSE=""
+
+DEPEND="sys-devel/binutils:*"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Fails to build due to missing header, bug #430706
+ epatch "${FILESDIR}"/${PN}-0.2-missing-header.patch
+}