summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-05-07 13:47:27 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-05-07 13:48:51 -0400
commit896a29cffd9ccd6f060d74a5193b6825338dd7c3 (patch)
treee51cdf356d2eabb79505f3571a4f20ad51f3eecf /dev-util/mingw64-toolchain
parentnet-libs/nodejs: fix build with GCC 14 (update simdjson to 3.9.1) (diff)
downloadgentoo-896a29cffd9ccd6f060d74a5193b6825338dd7c3.tar.gz
gentoo-896a29cffd9ccd6f060d74a5193b6825338dd7c3.tar.bz2
gentoo-896a29cffd9ccd6f060d74a5193b6825338dd7c3.zip
dev-util/mingw64-toolchain: IUSE=debug -> +strip
Forgot but meant to do this on a bump to avoid rebuilds, but given this isn't keyworded yet there is little harm in doing it now. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util/mingw64-toolchain')
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-11.0.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.1.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.1.ebuild
index 94e4af656ed4..4003b26827a8 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.1.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.1.ebuild
@@ -42,7 +42,7 @@ LICENSE="
SLOT="0"
# unkeyworded for testing
#KEYWORDS="-* ~amd64 ~x86"
-IUSE="+abi_x86_32 bin-symlinks custom-cflags debug"
+IUSE="+abi_x86_32 bin-symlinks custom-cflags +strip"
RDEPEND="
dev-libs/gmp:=
@@ -323,7 +323,7 @@ src_compile() {
dostrip -x ${mwtdir}/{${CTARGET}/lib{,32},lib/gcc/${CTARGET}}
# ... and instead do it here given this saves ~60MB
- if use !debug; then
+ if use strip; then
einfo "Stripping ${CTARGET} static libraries ..."
find "${sysroot}"/{,lib/gcc/}${CTARGET} -type f -name '*.a' \
-exec ${CTARGET}-strip --strip-unneeded {} + || die