summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-07-30 23:04:51 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-07-30 23:06:26 -0500
commit9ed1f89243f39a958d7ecbaf567f6cc1948ac7c4 (patch)
treec30824093872cb78d5c332f34028be7b6f2b3ec0 /dev-util/gitlab-runner
parentapp-text/calibre: backport fix for CVE-2024-7008 to 5.44 (diff)
downloadgentoo-9ed1f89243f39a958d7ecbaf567f6cc1948ac7c4.tar.gz
gentoo-9ed1f89243f39a958d7ecbaf567f6cc1948ac7c4.tar.bz2
gentoo-9ed1f89243f39a958d7ecbaf567f6cc1948ac7c4.zip
dev-util/gitlab-runner: add 17.2.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-17.2.1.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 6e205b8ce2a1..b62ab9f6a415 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -4,3 +4,5 @@ DIST gitlab-runner-17.1.0-deps.tar.xz 86656984 BLAKE2B 7766a3764d8ba17e3943f16a6
DIST gitlab-runner-17.1.0.tar.bz2 1372603 BLAKE2B 1600fbc4ec5eb2b7190424f9f2877e1938bad33b683fefd750e541f72e6d9ee4bf05c1c65de030c9022211333bbfce768bbd96ab750c46153c491d301ec63c6f SHA512 1904bac24b5f9b7bdbd18c7a7c32e875bbfb1017c34441e83a9970624a48c8bbeb3a59f926303ae3a2a28586107f29a5849bee0f17acb8dfdb6e2f7ae904c3b9
DIST gitlab-runner-17.2.0-deps.tar.xz 86664672 BLAKE2B 95d542400ac07c77ef2be39b42c2615d2593869e6ae6fb48b89f2c06dc1da80dc95c3833b6bf9a089bb1fbdb9b4565fa788a74ddb39c27bd5e76cacb5be0d3ac SHA512 c08dcf3b6d9eae16b20f1bc62964012a5923f4ef9f53f357c8af23cdbe8fb4f519a87f62e05d3b5dee8a96e9ef7c27a1178569d33cb97695ce41372bcb6d3fc7
DIST gitlab-runner-17.2.0.tar.bz2 1377145 BLAKE2B dc9a06743387e45ecd9c44269b4b8703d41413e783908d21024eea2ee09ef9ee8c277cf9ae831ba0058fd9d14ced088722e34788a6338214373cb61b101075d7 SHA512 568dc0198f87e25103183f0279b0c12af154a9009c9986be9e481f53b34d0a408e1e323a743181e5b4133a7e5af0da448dd2e0211918089e9608eca0aeaa468f
+DIST gitlab-runner-17.2.1-deps.tar.xz 86661500 BLAKE2B 96700ef116677e2fa0d2233475906563b54d7d422ff25612439f0b6530592e24f472b9645d4faff4dd2f98ea37d0f8ad1242ee7ef532a6d7204d582925a50ae3 SHA512 f40317a3d3e9c873c8ba486d6b4c82d233166fc175ed7f8e6563d8a217d80b806f730b4f22e5879568528035961a6fc120b87ce8e9ea2eb9232ba8623b7e407e
+DIST gitlab-runner-17.2.1.tar.bz2 1378845 BLAKE2B 649217da0c358e8db87758c72bd69897b1d9edd0b9e9d92c9a42ce7b39b5fa8bef7a07faf107584d90aae8ce292e0625b2a021294cd9b8cff73c02d086a5cda7 SHA512 3c14643da0884bc6bdf1eebfababb1ffa7d2ecf93ec1b0e708aef143b8a9519bc7d27fb6a3fdf6f6fb5b04511a8f1cfd9622c9c5db4365c879dc30c8a4d59cb6
diff --git a/dev-util/gitlab-runner/gitlab-runner-17.2.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-17.2.1.ebuild
new file mode 100644
index 000000000000..39708682b2bd
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-17.2.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=9882d9c7
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}