summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-01-30 22:51:43 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-01-30 22:51:43 +0700
commit5c9447eca4abd8acf080938192a3d0eda3fc4516 (patch)
tree7671ce4f0bc89d20670d99bbfe93cc87ae07701f /dev-util/diffuse
parentprofiles: mask discount-3 due to broken revdeps (diff)
downloadgentoo-5c9447eca4abd8acf080938192a3d0eda3fc4516.tar.gz
gentoo-5c9447eca4abd8acf080938192a3d0eda3fc4516.tar.bz2
gentoo-5c9447eca4abd8acf080938192a3d0eda3fc4516.zip
dev-util/diffuse: bump to 0.7.7
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-util/diffuse')
-rw-r--r--dev-util/diffuse/Manifest1
-rw-r--r--dev-util/diffuse/diffuse-0.7.7.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/diffuse/Manifest b/dev-util/diffuse/Manifest
index 7b0d98557a35..5b0592b6f66d 100644
--- a/dev-util/diffuse/Manifest
+++ b/dev-util/diffuse/Manifest
@@ -1 +1,2 @@
DIST diffuse-0.7.5.tar.gz 509048 BLAKE2B f69d9afea243069bdb9d313059556cc83283cd037e2f32de4b1221a2b53c493cb8a0a9bf8b4fc4d8a50e94fc60fe6043d30e3b5e7b7ceb2cec8529d8e136db0f SHA512 466cdc834e1103ad794979a287838b5005379712ee1d77e400d5fe71dcf5e79097decb39e26b213669077a4a2a525444db99b5587929f01b8b2df9f31ec190fd
+DIST diffuse-0.7.7.tar.gz 620577 BLAKE2B 5c6cf09519e177404dd4d0fd8b27d176581ac08fb9d6dac5b4a90b130f7c28fce0f0f3802a99c7b3078e608f967a36851532d43f5e661854755242b5b23a64e8 SHA512 bf9576734ebd696252732b3b0ce6f1f18508a800520388459d9f27482a43251db879c2198c3a279bad9528afc08cf8e7f23a3253b58edad049db9b1c697fd6e0
diff --git a/dev-util/diffuse/diffuse-0.7.7.ebuild b/dev-util/diffuse/diffuse-0.7.7.ebuild
new file mode 100644
index 000000000000..4b47edc65ee9
--- /dev/null
+++ b/dev-util/diffuse/diffuse-0.7.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+PLOCALES="cs de es fr it ja ko pl pt pt_BR ru sv th zh_CN zh_TW"
+inherit meson plocale python-r1 xdg
+
+DESCRIPTION="A graphical tool to compare and merge text files"
+HOMEPAGE="http://diffuse.sourceforge.net/ https://github.com/MightyCreak/diffuse/"
+SRC_URI="https://github.com/MightyCreak/diffuse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ ')
+ x11-libs/gtk+:3[introspection]"
+# file collision, bug #279018
+DEPEND="${DEPEND}
+ !sci-chemistry/tinker"
+
+src_prepare() {
+ default
+ plocale_find_changes po '' '.po'
+
+ rm_locale() {
+ rm -f po/${1}.po
+ rm -rf data/usr/share/man/${1}
+ rm -rf data/usr/share/gnome/help/${PN}/$1
+ rm -f data/usr/share/omf/${PN}/${PN}-$1.omf
+ sed -e "/^${1}/d" -i po/LINGUAS
+ }
+
+ plocale_for_each_disabled_locale rm_locale
+}
+
+src_install() {
+ meson_src_install
+ rm "${D}"/usr/bin/${PN} || die "rm ${PN} failed"
+ python_foreach_impl python_doscript ../${P}-build/src/${PN}/${PN}
+ mkdir "${D}"/usr/share/metainfo || die "mkdir metainfo failed"
+ mv "${D}"/usr/share/appdata/* "${D}"/usr/share/metainfo/ \
+ || die "mv appdata -> metainfo failed"
+ dodoc AUTHORS CHANGELOG.md README.md
+}