summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-03-20 13:03:53 +0100
committerHans de Graaff <graaff@gentoo.org>2024-03-20 13:04:47 +0100
commitdb3dab5b1d105504faa8d7d9f03287fa049c8019 (patch)
treeffd3b5f0b6a23c9d131cac73d1cb7bbc83358bbc /dev-ruby
parentdev-ruby/rspec-rails: add 6.1.2 (diff)
downloadgentoo-db3dab5b1d105504faa8d7d9f03287fa049c8019.tar.gz
gentoo-db3dab5b1d105504faa8d7d9f03287fa049c8019.tar.bz2
gentoo-db3dab5b1d105504faa8d7d9f03287fa049c8019.zip
dev-ruby/ruby-progressbar: add ruby33
Drop dependency on unmaintained and broken rspectacular. Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0-r1.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0-r1.ebuild
new file mode 100644
index 000000000000..b8659a7f3211
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="ruby-progressbar.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+SRC_URI="https://github.com/jfelchner/ruby-progressbar/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-progressbar-releases-v${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+ruby_add_bdepend "test? ( dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -e '/warning_filter/ s:^:#:' \
+ -e '/rspectacular/arequire "ruby-progressbar"; require "timecop"' \
+ -e '/rspectacular/ s:^:#:' \
+ -i spec/spec_helper.rb || die
+}