summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-10-25 08:13:49 +0200
committerHans de Graaff <graaff@gentoo.org>2024-10-25 08:31:13 +0200
commit581e032f61d9bc3b7764fc4dbbb5fad3df1a8ee2 (patch)
treeb1b07d0652cd31c70ea446321460870c6dec6e91 /dev-ruby
parentdev-ruby/json: update upstream metadata (diff)
downloadgentoo-581e032f61d9bc3b7764fc4dbbb5fad3df1a8ee2.tar.gz
gentoo-581e032f61d9bc3b7764fc4dbbb5fad3df1a8ee2.tar.bz2
gentoo-581e032f61d9bc3b7764fc4dbbb5fad3df1a8ee2.zip
dev-ruby/json: drop 2.7.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/json/json-2.7.2.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-ruby/json/json-2.7.2.ebuild b/dev-ruby/json/json-2.7.2.ebuild
deleted file mode 100644
index 844c416f9c52..000000000000
--- a/dev-ruby/json/json-2.7.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby31 ruby32 ruby33"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="json.gemspec"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/json/ext/parser/extconf.rb ext/json/ext/generator/extconf.rb)
-RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/json/ext
-
-inherit ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension"
-HOMEPAGE="https://github.com/flori/json"
-SRC_URI="https://github.com/flori/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="|| ( BSD-2 Ruby )"
-
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-SLOT="$(ver_cut 1)"
-IUSE="doc test"
-
-DEPEND="${DEPEND}
- =dev-util/ragel-6*"
-
-ruby_add_bdepend "dev-ruby/rake
- doc? ( dev-ruby/rdoc )
- test? (
- dev-ruby/test-unit:2
- dev-ruby/test-unit-ruby-core
- )"
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- # And use rdoc instead of sdoc which we don't have packaged
- # And don't call git to list files. We're using the pregenerated spec anyway.
- sed -i \
- -e '/task :test/ s|:compile,||' \
- -e 's| => :clean||' \
- -e 's|sdoc|rdoc|' \
- -e 's|`git ls-files`|""|' \
- Rakefile || die "rakefile fix failed"
-
- sed -e 's/__dir__/"."/' \
- -i ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Avoid setting gem since it will not be available yet when installing
- sed -i -e '/gem/ s:^:#:' tests/test_helper.rb || die
-}