summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-09-24 06:47:54 +0200
committerHans de Graaff <graaff@gentoo.org>2024-09-24 07:09:03 +0200
commit3b44d44658e07e7e9a505f484aa6b95bfcb2ef74 (patch)
treed0fa9147f77bbc4c0812416f8842467381c889d3 /dev-ruby
parentdev-ruby/activeldap: add 7.2.0 (diff)
downloadgentoo-3b44d44658e07e7e9a505f484aa6b95bfcb2ef74.tar.gz
gentoo-3b44d44658e07e7e9a505f484aa6b95bfcb2ef74.tar.bz2
gentoo-3b44d44658e07e7e9a505f484aa6b95bfcb2ef74.zip
dev-ruby/gettext_i18n_rails: enable ruby33
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/gettext_i18n_rails/files/gettext_i18n_rails-1.13.0-rails71.patch25
-rw-r--r--dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.13.0.ebuild10
2 files changed, 31 insertions, 4 deletions
diff --git a/dev-ruby/gettext_i18n_rails/files/gettext_i18n_rails-1.13.0-rails71.patch b/dev-ruby/gettext_i18n_rails/files/gettext_i18n_rails-1.13.0-rails71.patch
new file mode 100644
index 000000000000..b420547cfb09
--- /dev/null
+++ b/dev-ruby/gettext_i18n_rails/files/gettext_i18n_rails-1.13.0-rails71.patch
@@ -0,0 +1,25 @@
+From f88bd5b0e8869ec5b7992846e5562c414b36f380 Mon Sep 17 00:00:00 2001
+From: Hannes Hornwall <hannes@hornwall.me>
+Date: Tue, 30 Jul 2024 14:46:48 +0200
+Subject: [PATCH] Update test case with classes that are no longer included in
+ rails 7.1
+
+---
+ spec/gettext_i18n_rails/model_attributes_finder_spec.rb | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/spec/gettext_i18n_rails/model_attributes_finder_spec.rb b/spec/gettext_i18n_rails/model_attributes_finder_spec.rb
+index dec15865..9bdaf92a 100644
+--- a/spec/gettext_i18n_rails/model_attributes_finder_spec.rb
++++ b/spec/gettext_i18n_rails/model_attributes_finder_spec.rb
+@@ -24,8 +24,8 @@ class Application < Rails::Application
+ keys = finder.find({}).keys
+ expected = [CarSeat, Part, StiParent]
+ expected.concat [AbstractParentClass, NotConventional] if Rails::VERSION::MAJOR >= 3
+- expected.concat [ActiveRecord::SchemaMigration] if Rails::VERSION::MAJOR >= 4
+- expected.concat [ActiveRecord::InternalMetadata] if Rails::VERSION::MAJOR >= 5
++ expected.concat [ActiveRecord::SchemaMigration] if Rails::VERSION::MAJOR >= 4 && !(Rails::VERSION::MAJOR == 7 && Rails::VERSION::MINOR > 0)
++ expected.concat [ActiveRecord::InternalMetadata] if Rails::VERSION::MAJOR >= 5 && !(Rails::VERSION::MAJOR == 7 && Rails::VERSION::MINOR > 0)
+ keys.should =~ expected
+ end
+
diff --git a/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.13.0.ebuild b/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.13.0.ebuild
index b59e2668da8f..cee515a7a942 100644
--- a/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.13.0.ebuild
+++ b/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.13.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-USE_RUBY="ruby31 ruby32"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_EXTRADOC="Readme.md"
@@ -22,9 +22,11 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="test"
+PATCHES=( "${FILESDIR}/${P}-rails71.patch" )
+
ruby_add_bdepend "test? (
- dev-ruby/rails:7.0
- dev-ruby/activerecord:7.0[sqlite]
+ dev-ruby/rails:7.1
+ dev-ruby/activerecord:7.1[sqlite]
dev-ruby/temple
dev-ruby/ruby-gettext
dev-ruby/haml
@@ -42,5 +44,5 @@ all_ruby_prepare() {
rm spec/gettext_i18n_rails/slim_parser_spec.rb spec/gettext_i18n_rails/haml_parser_spec.rb || die
# Test against specific Rails version
- sed -e '1igem "rails", "~>7.0.0"' -i spec/spec_helper.rb || die
+ sed -e '1igem "rails", "~>7.1.0"' -i spec/spec_helper.rb || die
}