summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-28 07:03:23 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-28 07:03:23 +0200
commit5d8322f8b9b4339efeb78cea1f3c71234ded4aad (patch)
treed6539f77844a295ad583b08b3a7ff7af0293811f /dev-ruby/ref
parentprofiles/base: package.use.mask app-emulation/lxc[io-uring] (diff)
downloadgentoo-5d8322f8b9b4339efeb78cea1f3c71234ded4aad.tar.gz
gentoo-5d8322f8b9b4339efeb78cea1f3c71234ded4aad.tar.bz2
gentoo-5d8322f8b9b4339efeb78cea1f3c71234ded4aad.zip
dev-ruby/ref: add ruby30
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ref')
-rw-r--r--dev-ruby/ref/ref-2.0.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/ref/ref-2.0.0-r1.ebuild b/dev-ruby/ref/ref-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..1bdcb660db57
--- /dev/null
+++ b/dev-ruby/ref/ref-2.0.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="HISTORY.txt README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements weak, soft, and strong references in Ruby"
+HOMEPAGE="https://github.com/ruby-concurrency/ref"
+SRC_URI="https://github.com/ruby-concurrency/ref/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}