summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-11-19 21:38:33 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2024-11-19 21:38:33 -0600
commitf2667a7a52c23be4d07ed16ee03f15e5b9ec18db (patch)
treeb852b47c7fc3ca59edbe5ac093e8c9e55980add0 /dev-ruby/puppetdb-termini
parentapp-admin/puppetserver: add 8.7.0 (diff)
downloadgentoo-f2667a7a52c23be4d07ed16ee03f15e5b9ec18db.tar.gz
gentoo-f2667a7a52c23be4d07ed16ee03f15e5b9ec18db.tar.bz2
gentoo-f2667a7a52c23be4d07ed16ee03f15e5b9ec18db.zip
dev-ruby/puppetdb-termini: add 8.8.1
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-8.8.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 7203ee060df5..1c4e5d075144 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,3 +1,4 @@
DIST puppetdb-termini_7.13.0-1bullseye_all.deb 22548 BLAKE2B 535a3f846a7a10dcfaec4447ae852c6c4d870a573169f84e31f61c361164caea989f911df2d18e183c391dd0130a10b9422057eecaab304bebbb022f78e22a21 SHA512 3c8e440bfc55579d0c9a03ecae516d4cef49512ad9fdd6fceef37618c163ecac6d77a2b17b6cbb7131ceb3787904486bb78eef84a36a5f76672918db6d30db86
DIST puppetdb-termini_8.5.0-1focal_all.deb 22142 BLAKE2B e32985eee15ffc44dee5626c51edd09de2a6b2b936c8fb9308d34884871d693b246983056d2791a29341e450ba525a419c818b22390aa22cc9efd85696a1e007 SHA512 c4afc5618f83db64b083953a38070660ff4087141e09ff02ce218416eda53e6c16bf6c9f5eab2ebd2721f086c477902ebb1b34b2556eafdeb8f4d4260d9e9f00
DIST puppetdb-termini_8.7.0-1focal_all.deb 21836 BLAKE2B 34eabb3d759db1e6d49c6a93d96a333abc0cca31411ed9e33871fb1e1a9255cb75c530b2f8771a5132f364857064d23e2c706691a55a61eb1c2fc9669dc3bf2c SHA512 a7cc11f383752935a74a5bce37866a25b442c066cdaff14a858ad12d937bf6df6dd70159d3e74089432585921598141b931b2763e88d3d46ed79a0bb394e8e7c
+DIST puppetdb-termini_8.8.1-1focal_all.deb 22114 BLAKE2B ea699743c319cd2f854cc015a0f5ceefafb6b34784ab053040530cac360ca388ebdaf7d91e0a5e1de1874993867ccee6a2f5c579105a70537e6451727b1d279e SHA512 0af46b6302d487cde8225611fe77d24a2fdb76fe74b3e8060c4eae1c487ac6a71ec1ecf51adb78d38ffeb3aed5c7fa0f4b4bccab15057ddbed93b90cfdf15464
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-8.8.1.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-8.8.1.ebuild
new file mode 100644
index 000000000000..a1d1136f37f2
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-8.8.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby31 ruby32"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="https://puppet.com/docs/puppetdb/latest/index.html"
+SRC_URI="http://apt.puppetlabs.com/pool/focal/puppet8/${PN:0:1}/${PN}/${PN}_${PV}-1focal_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}