summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-04-07 10:23:06 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-04-07 10:23:06 -0500
commitd1f2ebb4bd27298acab70215c6435e0a9786a9b3 (patch)
tree2ea936e48c494e5af74a8428fb5e854f4febe8da /dev-ruby/puppetdb-termini/puppetdb-termini-7.13.0.ebuild
parentapp-admin/puppetdb: add 7.13.0 (diff)
downloadgentoo-d1f2ebb4bd27298acab70215c6435e0a9786a9b3.tar.gz
gentoo-d1f2ebb4bd27298acab70215c6435e0a9786a9b3.tar.bz2
gentoo-d1f2ebb4bd27298acab70215c6435e0a9786a9b3.zip
dev-ruby/puppetdb-termini: add 7.13.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini/puppetdb-termini-7.13.0.ebuild')
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-7.13.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-7.13.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-7.13.0.ebuild
new file mode 100644
index 000000000000..21001dc94028
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-7.13.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="https://puppet.com/docs/puppetdb/latest/index.html"
+SRC_URI="http://apt.puppetlabs.com/pool/bullseye/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1bullseye_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}