summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/pkg-config
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/pkg-config')
-rw-r--r--dev-ruby/pkg-config/Manifest2
-rw-r--r--dev-ruby/pkg-config/metadata.xml11
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.1.5-r1.ebuild34
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.1.5.ebuild34
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.1.6.ebuild34
5 files changed, 115 insertions, 0 deletions
diff --git a/dev-ruby/pkg-config/Manifest b/dev-ruby/pkg-config/Manifest
new file mode 100644
index 000000000000..50402ad0a65b
--- /dev/null
+++ b/dev-ruby/pkg-config/Manifest
@@ -0,0 +1,2 @@
+DIST pkg-config-1.1.5.gem 19456 SHA256 c821a08679b447e9665639d7c12b6a1d566530dcc9920c2d5dfd5e2e7cab06a7 SHA512 3f5fa5f255dc8c8838eb742e0b3654de7d00155fe8c41e007ae51cc01c5380182a24ee0b4718d76e5b76ad1deb917d429db61d3ffc995a774381722749b82cdd WHIRLPOOL 8d281d5b02cb71fdcb5dd899b817ac255b81db070f892f05ab312f21716f61805e954e8b882442deb9de04bb80e302648997ae206faaa5f3eb505447d82c05cd
+DIST pkg-config-1.1.6.gem 19456 SHA256 f89c285286d9bb1607022225d042d8ff96d41d2755d4de80611d52f3ab0f7626 SHA512 089aec86cf008d1dca3fa6ee6604ef5860cd404671e23b539eb82a4654255eecddd142d0249e0c89dad7a467a5252ed3afea665cda8bb4012ae5ec8e24d2d825 WHIRLPOOL 619d85ad9e7ce5adaf4731abebbbe2e089571defac38f147c528e1f0a99d0f5345e0ecb7b0f27c999353dc5b4e22df0771a25403a6c31d1cb550664c3fbcfef8
diff --git a/dev-ruby/pkg-config/metadata.xml b/dev-ruby/pkg-config/metadata.xml
new file mode 100644
index 000000000000..83a8f2600154
--- /dev/null
+++ b/dev-ruby/pkg-config/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <maintainer>
+ <email>naota@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rcairo/pkg-config</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/pkg-config/pkg-config-1.1.5-r1.ebuild b/dev-ruby/pkg-config/pkg-config-1.1.5-r1.ebuild
new file mode 100644
index 000000000000..4decff3c1767
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.1.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+# drop failing tests
+ sed -i -e "/test_cflags/,/end/d"\
+ -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb
+}
diff --git a/dev-ruby/pkg-config/pkg-config-1.1.5.ebuild b/dev-ruby/pkg-config/pkg-config-1.1.5.ebuild
new file mode 100644
index 000000000000..0ac810804417
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="amd64 ppc ppc64 x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+# drop failing tests
+ sed -i -e "/test_cflags/,/end/d"\
+ -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb
+}
diff --git a/dev-ruby/pkg-config/pkg-config-1.1.6.ebuild b/dev-ruby/pkg-config/pkg-config-1.1.6.ebuild
new file mode 100644
index 000000000000..68aab95a030c
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.1.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+# drop failing tests
+ sed -i -e "/test_cflags/,/end/d"\
+ -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb
+}