summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/omniauth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/omniauth')
-rw-r--r--dev-ruby/omniauth/Manifest2
-rw-r--r--dev-ruby/omniauth/metadata.xml8
-rw-r--r--dev-ruby/omniauth/omniauth-1.2.1.ebuild40
-rw-r--r--dev-ruby/omniauth/omniauth-1.2.2.ebuild40
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-ruby/omniauth/Manifest b/dev-ruby/omniauth/Manifest
new file mode 100644
index 000000000000..0f117449aa93
--- /dev/null
+++ b/dev-ruby/omniauth/Manifest
@@ -0,0 +1,2 @@
+DIST omniauth-1.2.1.gem 33280 SHA256 fd545593bd19b506d41e39dd830c62fd541eb4df0861a1bc99b6e357456ed9fe SHA512 4a06bc7a473240a17de15b55c10cbc6150eaa98aa0efd66e7c7b2ef5abb55248776ce88a3de5e576a7517498847b02249d084136f9209051b1ee8c07831c8da1 WHIRLPOOL 09953f36a2999f357fac557435f91e5555851bdcb3ab15f2aa04afd4980c5b32ca7b18b3bbfe9b59d06c89ca95fe422b78461739e2e7667c41a83a87c03a7f03
+DIST omniauth-1.2.2.gem 27648 SHA256 939eabc200dc19d624ad02020b9f9258a69429b2250b883e47ce2cf76c6a10b8 SHA512 5451ad281be5cd1dc45c66d295476f182904d08818c23a08a6245dbb517eeb49b29ff5810f67680073fb4cde2407eee164a2aae2b06397d7ea71b149fb86789e WHIRLPOOL d7ca6d180eea30583163a2eb60d14498c09fbd1baf78b1e6539e187028a5f943c7f7dd0f3a47a9b95acb59995f8c7bf39eb6a53b69cfb1fa9d39e87010975c7b
diff --git a/dev-ruby/omniauth/metadata.xml b/dev-ruby/omniauth/metadata.xml
new file mode 100644
index 000000000000..df5a6cd9d02b
--- /dev/null
+++ b/dev-ruby/omniauth/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">intridea/omniauth</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/omniauth/omniauth-1.2.1.ebuild b/dev-ruby/omniauth/omniauth-1.2.1.ebuild
new file mode 100644
index 000000000000..dd74ebf9c6aa
--- /dev/null
+++ b/dev-ruby/omniauth/omniauth-1.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generalized Rack framework for multiple-provider authentication"
+HOMEPAGE="https://github.com/intridea/omniauth"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack dev-ruby/hashie"
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/rack-test )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' \
+ Rakefile ${PN}.gemspec || die "sed failed"
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/helper.rb || die "sed failed"
+ # maruku fails, resorting to default markdown implementation
+ sed -i -e '/maruku/d' .yardopts || die "sed failed"
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die "yard failed"
+ fi
+}
diff --git a/dev-ruby/omniauth/omniauth-1.2.2.ebuild b/dev-ruby/omniauth/omniauth-1.2.2.ebuild
new file mode 100644
index 000000000000..1897d02ffc79
--- /dev/null
+++ b/dev-ruby/omniauth/omniauth-1.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generalized Rack framework for multiple-provider authentication"
+HOMEPAGE="https://github.com/intridea/omniauth"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack dev-ruby/hashie"
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/rack-test )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' \
+ Rakefile ${PN}.gemspec || die "sed failed"
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/helper.rb || die "sed failed"
+ # maruku fails, resorting to default markdown implementation
+ sed -i -e '/maruku/d' .yardopts || die "sed failed"
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die "yard failed"
+ fi
+}