summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-09-10 18:51:42 +0200
committerHans de Graaff <graaff@gentoo.org>2023-09-10 18:57:37 +0200
commit8fe538b09d3eae012ef5bdc99832a445304a8a69 (patch)
treefc7d67b9dd3cf953a750c2dd70507aec86373649 /dev-ruby/image_processing
parentapp-shells/autojump: Migrate to PEP517 build (diff)
downloadgentoo-8fe538b09d3eae012ef5bdc99832a445304a8a69.tar.gz
gentoo-8fe538b09d3eae012ef5bdc99832a445304a8a69.tar.bz2
gentoo-8fe538b09d3eae012ef5bdc99832a445304a8a69.zip
dev-ruby/image_processing: fix minitest deprecation
Closes: https://bugs.gentoo.org/911953 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/image_processing')
-rw-r--r--dev-ruby/image_processing/image_processing-1.12.2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-ruby/image_processing/image_processing-1.12.2.ebuild b/dev-ruby/image_processing/image_processing-1.12.2.ebuild
index 8442915b178d..0e84e582aef1 100644
--- a/dev-ruby/image_processing/image_processing-1.12.2.ebuild
+++ b/dev-ruby/image_processing/image_processing-1.12.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+USE_RUBY="ruby30 ruby31 ruby32"
RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md doc/*.md"
@@ -42,4 +42,7 @@ all_ruby_prepare() {
sed -i -e '/\(assert\|refute\)_similar/ s:^:#:' test/*_test.rb || die
sed -i -e '/\(bundler\|phashion\|vips\)/ s:^:#:' Rakefile test/test_helper.rb || die
+
+ # Fix minitest deprecation
+ sed -i -e 's/MiniTest/Minitest/' test/test_helper.rb || die
}