summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-16 08:32:16 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-16 08:45:33 +0200
commite6cf369ade36fad7c6bbb896f36d841e533c9d66 (patch)
treeffa3ebccb95c54fe5a399f9b02126a287448b779 /dev-ruby/awesome_print
parentdev-ruby/amatch: add 0.4.0 (diff)
downloadgentoo-e6cf369ade36fad7c6bbb896f36d841e533c9d66.tar.gz
gentoo-e6cf369ade36fad7c6bbb896f36d841e533c9d66.tar.bz2
gentoo-e6cf369ade36fad7c6bbb896f36d841e533c9d66.zip
dev-ruby/awesome_print: add 1.8.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/awesome_print')
-rw-r--r--dev-ruby/awesome_print/Manifest1
-rw-r--r--dev-ruby/awesome_print/awesome_print-1.8.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/awesome_print/Manifest b/dev-ruby/awesome_print/Manifest
index 7009947eaaf0..b19371b87375 100644
--- a/dev-ruby/awesome_print/Manifest
+++ b/dev-ruby/awesome_print/Manifest
@@ -1 +1,2 @@
DIST awesome_print-1.7.0.tar.gz 39436 SHA256 9f844b1f085718d5ba1968be79614dc93202b05166df4b09649e974db37e9634 SHA512 a49cf98c373ccc39a3f80b8ba531edb1f1bb63ba2dea10339aa3cdeae3e63863043c6a5fb0143569e1a50b2e340256210a170cccda3fc609aa3fccef20cfd080 WHIRLPOOL b6c9c5b3fde85618448145f050b7fe4cd9ea067c254bb25beb4dcc98e128597a1f2546022548d3a8502417f98bad04fb321021188ea7211e0087380dd56db225
+DIST awesome_print-1.8.0.tar.gz 42605 SHA256 97589bcb4abad8159218aa8e45d3d61b6951f16ffc99b673f4968ec0bc08d9b8 SHA512 72ac5c4d918c84adba5ea7a60502ac89d57c5734b0b557d0171caae86b5f13ce316c5d7717315ff56c7f7a0959efeb244b6b85f4147c14ec8bf9e128488cf480 WHIRLPOOL a6ab43069459ee4bdff33f519a71aa7f300db2eb8e27180e9768bf457f3a8d3a0eacbb9feea522732032ec0725d05c50d242524c9dd9c907e684922e7b4f9caf
diff --git a/dev-ruby/awesome_print/awesome_print-1.8.0.ebuild b/dev-ruby/awesome_print/awesome_print-1.8.0.ebuild
new file mode 100644
index 000000000000..7caeb5ca5ecb
--- /dev/null
+++ b/dev-ruby/awesome_print/awesome_print-1.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library to pretty print Ruby objects in full color with proper indentation"
+HOMEPAGE="https://github.com/awesome-print/awesome_print"
+SRC_URI="https://github.com/awesome-print/awesome_print/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc64 ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/nokogiri
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/codeclimate/I s:^:#:' \
+ -e '/simplecov/I s:^:#:' \
+ spec/spec_helper.rb || die
+
+ # Avoid activerecord specs since they don't run
+ # consistently accross rails versions and not all
+ # arches have rails
+ rm -f spec/ext/active_record_spec.rb || die
+}