summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-03 11:54:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-03 12:50:26 +0200
commit19038f469dccf791114875804343ca423f2d246b (patch)
treec87ad610ee6f063cc0e6a0b951c14d3285c38773 /dev-ros/xmlrpcpp/xmlrpcpp-1.15.11.ebuild
parentdev-ros/roslz4: Bump to 1.15.11. (diff)
downloadgentoo-19038f469dccf791114875804343ca423f2d246b.tar.gz
gentoo-19038f469dccf791114875804343ca423f2d246b.tar.bz2
gentoo-19038f469dccf791114875804343ca423f2d246b.zip
dev-ros/xmlrpcpp: Bump to 1.15.11.
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/xmlrpcpp/xmlrpcpp-1.15.11.ebuild')
-rw-r--r--dev-ros/xmlrpcpp/xmlrpcpp-1.15.11.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/xmlrpcpp/xmlrpcpp-1.15.11.ebuild b/dev-ros/xmlrpcpp/xmlrpcpp-1.15.11.ebuild
new file mode 100644
index 000000000000..f3fb15501966
--- /dev/null
+++ b/dev-ros/xmlrpcpp/xmlrpcpp-1.15.11.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ implementation of the XML-RPC protocol"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/gtest
+ dev-libs/boost[threads(+)]
+ )
+"