summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 12:30:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:20:57 +0200
commite2a6b48650c24a2864f6e4890c4bfad00af4b2be (patch)
tree18ea327b34aaa804ebee5d9bf3e3b1c71fd9e0ba /dev-ros/topic_tools/topic_tools-1.15.8.ebuild
parentdev-ros/rostopic: Bump to 1.15.8. (diff)
downloadgentoo-e2a6b48650c24a2864f6e4890c4bfad00af4b2be.tar.gz
gentoo-e2a6b48650c24a2864f6e4890c4bfad00af4b2be.tar.bz2
gentoo-e2a6b48650c24a2864f6e4890c4bfad00af4b2be.zip
dev-ros/topic_tools: Bump to 1.15.8.
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/topic_tools/topic_tools-1.15.8.ebuild')
-rw-r--r--dev-ros/topic_tools/topic_tools-1.15.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/topic_tools/topic_tools-1.15.8.ebuild b/dev-ros/topic_tools/topic_tools-1.15.8.ebuild
new file mode 100644
index 000000000000..80ec72e7c712
--- /dev/null
+++ b/dev-ros/topic_tools/topic_tools-1.15.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=tools/${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for directing, throttling and selecting ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostime
+ dev-ros/xmlrpcpp
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"