summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-06 13:13:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-06 14:28:33 +0200
commitb4eef9c524b555617e5dbd5d506e0c8571b91070 (patch)
tree8b7d3d24e7cce102e110287ca1112b679a647248 /dev-ros/timestamp_tools
parentdev-ros/collada_urdf: add missing test dep (diff)
downloadgentoo-b4eef9c524b555617e5dbd5d506e0c8571b91070.tar.gz
gentoo-b4eef9c524b555617e5dbd5d506e0c8571b91070.tar.bz2
gentoo-b4eef9c524b555617e5dbd5d506e0c8571b91070.zip
dev-ros/timestamp_tools: fix for newer boost
Closes: https://bugs.gentoo.org/690374 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/timestamp_tools')
-rw-r--r--dev-ros/timestamp_tools/files/boost.patch13
-rw-r--r--dev-ros/timestamp_tools/timestamp_tools-1.6.8-r1.ebuild (renamed from dev-ros/timestamp_tools/timestamp_tools-1.6.8.ebuild)3
-rw-r--r--dev-ros/timestamp_tools/timestamp_tools-9999.ebuild1
3 files changed, 16 insertions, 1 deletions
diff --git a/dev-ros/timestamp_tools/files/boost.patch b/dev-ros/timestamp_tools/files/boost.patch
new file mode 100644
index 000000000000..de7878ca19b8
--- /dev/null
+++ b/dev-ros/timestamp_tools/files/boost.patch
@@ -0,0 +1,13 @@
+Index: timestamp_tools/include/timestamp_tools/trigger_matcher.h
+===================================================================
+--- timestamp_tools.orig/include/timestamp_tools/trigger_matcher.h
++++ timestamp_tools/include/timestamp_tools/trigger_matcher.h
+@@ -266,7 +266,7 @@ public:
+ if (stamp != RetryLater)
+ return stamp;
+
+- got_trigger_condition_.timed_wait(lock, boost::posix_time::microseconds(timeout * 1e6));
++ got_trigger_condition_.timed_wait(lock, boost::posix_time::microseconds(static_cast<int>(timeout * 1e6)));
+
+ return getTimestampNoblockPrelocked(t);
+ }
diff --git a/dev-ros/timestamp_tools/timestamp_tools-1.6.8.ebuild b/dev-ros/timestamp_tools/timestamp_tools-1.6.8-r1.ebuild
index bb92a2937937..f43b7fcc4744 100644
--- a/dev-ros/timestamp_tools/timestamp_tools-1.6.8.ebuild
+++ b/dev-ros/timestamp_tools/timestamp_tools-1.6.8-r1.ebuild
@@ -19,4 +19,5 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
-PATCHES=( "${FILESDIR}/tests.patch" )
+PATCHES=( "${FILESDIR}/tests.patch" "${FILESDIR}/boost.patch" )
+
diff --git a/dev-ros/timestamp_tools/timestamp_tools-9999.ebuild b/dev-ros/timestamp_tools/timestamp_tools-9999.ebuild
index 5c96c2266bfb..86be358b9919 100644
--- a/dev-ros/timestamp_tools/timestamp_tools-9999.ebuild
+++ b/dev-ros/timestamp_tools/timestamp_tools-9999.ebuild
@@ -19,3 +19,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/boost.patch" )