summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 16:43:40 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:20:00 +0200
commit9a4f3a1f7261edb21dd2bbc27196f7183cd4d239 (patch)
tree54e06ad946f24e1e39f055630cace24e374b6d2f /dev-ros/rqt_bag_plugins
parentdev-ros/actionlib: convert to python-single-r1 (diff)
downloadgentoo-9a4f3a1f7261edb21dd2bbc27196f7183cd4d239.tar.gz
gentoo-9a4f3a1f7261edb21dd2bbc27196f7183cd4d239.tar.bz2
gentoo-9a4f3a1f7261edb21dd2bbc27196f7183cd4d239.zip
dev-ros/rqt_bag_plugins: convert to python-single-r1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_bag_plugins')
-rw-r--r--dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.13.ebuild16
-rw-r--r--dev-ros/rqt_bag_plugins/rqt_bag_plugins-9999.ebuild16
2 files changed, 16 insertions, 16 deletions
diff --git a/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.13.ebuild b/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.13.ebuild
index 3b6202e01f88..f0c32428d755 100644
--- a/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.13.ebuild
+++ b/dev-ros/rqt_bag_plugins/rqt_bag_plugins-0.4.13.ebuild
@@ -16,14 +16,14 @@ IUSE=""
RDEPEND="
dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-ros/rosbag[${PYTHON_USEDEP}]
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/rqt_bag[${PYTHON_USEDEP}]
- dev-ros/rqt_gui[${PYTHON_USEDEP}]
- dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pycairo[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/pillow[\${PYTHON_USEDEP}]")
+ dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_bag[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
"
diff --git a/dev-ros/rqt_bag_plugins/rqt_bag_plugins-9999.ebuild b/dev-ros/rqt_bag_plugins/rqt_bag_plugins-9999.ebuild
index 3b6202e01f88..f0c32428d755 100644
--- a/dev-ros/rqt_bag_plugins/rqt_bag_plugins-9999.ebuild
+++ b/dev-ros/rqt_bag_plugins/rqt_bag_plugins-9999.ebuild
@@ -16,14 +16,14 @@ IUSE=""
RDEPEND="
dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-ros/rosbag[${PYTHON_USEDEP}]
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/rqt_bag[${PYTHON_USEDEP}]
- dev-ros/rqt_gui[${PYTHON_USEDEP}]
- dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pycairo[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/pillow[\${PYTHON_USEDEP}]")
+ dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_bag[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
"