summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 15:47:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:28 +0200
commit0a687d4de8007a094761c5b801b60b636d0195fb (patch)
tree2b255db55faab257b0d8838a3a5ba586c1cb6bc6 /dev-ros/rostopic/rostopic-9999.ebuild
parentdev-ros/rosservice: Initial import. Ebuild by me. (diff)
downloadgentoo-0a687d4de8007a094761c5b801b60b636d0195fb.tar.gz
gentoo-0a687d4de8007a094761c5b801b60b636d0195fb.tar.bz2
gentoo-0a687d4de8007a094761c5b801b60b636d0195fb.zip
dev-ros/rostopic: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rostopic/rostopic-9999.ebuild')
-rw-r--r--dev-ros/rostopic/rostopic-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/rostopic/rostopic-9999.ebuild b/dev-ros/rostopic/rostopic-9999.ebuild
new file mode 100644
index 000000000000..c3438a04756b
--- /dev/null
+++ b/dev-ros/rostopic/rostopic-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS Topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"