summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-14 12:21:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-14 13:04:59 +0200
commitadcee895e0f217a1c3d6b41682821466b7808717 (patch)
treee0e8f9ad7b51901b591cdd51dcdbdcaeb3fea5d9 /dev-ros/rosserial_arduino/rosserial_arduino-0.9.1.ebuild
parentdev-ros/rqt_launch: bump to 0.4.9 (diff)
downloadgentoo-adcee895e0f217a1c3d6b41682821466b7808717.tar.gz
gentoo-adcee895e0f217a1c3d6b41682821466b7808717.tar.bz2
gentoo-adcee895e0f217a1c3d6b41682821466b7808717.zip
dev-ros/rosserial_arduino: Bump to 0.9.1.
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosserial_arduino/rosserial_arduino-0.9.1.ebuild')
-rw-r--r--dev-ros/rosserial_arduino/rosserial_arduino-0.9.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rosserial_arduino/rosserial_arduino-0.9.1.ebuild b/dev-ros/rosserial_arduino/rosserial_arduino-0.9.1.ebuild
new file mode 100644
index 000000000000..f444499009fb
--- /dev/null
+++ b/dev-ros/rosserial_arduino/rosserial_arduino-0.9.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Libraries and examples for ROSserial usage on Arduino/AVR Platforms"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosserial_client[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"